Transferred call allows one way audio only on polycoms

Finally upgraded to from 1.0.x which we have been using for years. Now when we transfer a call to a polycom phone (we use 600s) the call rings and is picked up, but the recipient cannot hear the original caller. The original caller CAN hear the recipient! Doesn’t happen when we transfer to a Grandstream phone, yet they are set up identically in extensions.conf.
Does v1.4x require changes to the Polycom setup? Anyone know what they might be?

(BTW: setting the verbosity high reveals nothing remarkable… no errors, successful transfer of the call, etc.)


I am using a 1.4.11 and Polycom IP301 without any issue with regards to transfer, either in native bridging or back to back UA. Nothing special on the Polycom.

You could maybe check a sniffer trace at the Asterisk level to validate SIP & RTP flows.

Regards, Alex.

Do you know if you are running the most up to date Polycom firmware on your Polycom phones? Perhaps that is why your setup is working and mine is not? I see that Polycom has an updated firmware for the 600 which is said to correct an issue of “one way audio after multiple transfers”, but I can’t get that firmware. (Their site allows only Certified Resellers to get the latest firmware for some reason, and the resellers don’t know anything about it and can’t or won’t help.)
I just don’t understand why the older Polycom firmware would have worked with Asterisk 1.0x and not with 1.4x, which still has me believing there has to be some setup change I need to implement.
Management is getting impatient… anybody have any other suggestions?

Polycom updates:

I give up. The Polycom firmware upgrades did no good for this issue. I had to purchase all new Grandstream phones so we could be in business. I just can’t believe no one else has ever had this problem.
Still keeping this topic open, if anyone hears anything that could help please let me know.

Last message I said I gave up, but I really didn’t; I kept working on the problem and I finally solved it.
In case anyone else out there is having a similar problem, read the long explanation at
It appears that Asterisk introduced a new behavior with v1.4x that attempts to emulate (but not really duplicate) a true SIP proxy by connecting one extension directly to another (before v1.4x, Asterisk “stayed in the middle” of each transfer so it could provide additional services). The problem is that it doesn’t really remove itself from the mix, and certain phones (Polycom was not mentioned in the article but I can tell you that Polycom is one of them) cannot handle this new arrangement.
The solution is to add “canreinvite=no” to the sip.conf file. This forces Asterisk to revert to the previous behavior which works with Polycom (each phone communicates with Asterisk, but never directly with each other). The result is some additional resource requirements on the Asterisk server, but hey, it works.
I’d love to know if this helped anyone else…