TLS SIP socket Error -- Connection timed out

What is following error?
[Feb 6 09:41:33] ERROR[24923]: tcptls.c:375 ast_tcptls_client_start: Unable to connect SIP socket to Connection timed out

Asterisk Version = 1.8.2, Ubuntu 2.6.32-21-server. = IP of peer.

Asterisk failed to receive a reponse to its attempt to make a TLS connection to the peer, i.e. what the messages says. This is likely to be a firewall or NAT problem.

I only face this problem with TLS, if i change peer to UDP peer do go online. If i change it back to TLS i get same message and peer do not go online.

Please suggest.

I am facing this issue without firewall too. Please suggest.

You have specified port 5060 explicitly for TLS? TLS runs on 5061 by default.

Yes it is 5061, but the error i get says 5060. I copied error from asterisk cli.

What’s the client?

Client is Cisco/Linksys SPA 2102.
Note if i change the SPA to UDP it works. If i change it back to TLS it will not even register and i see same error on CLI.

I don’t have one of those to test against. Try something like Blink (, if it works, then it’s something to do with the Cisco.


Hi Malcolmd,
I do not think it is SPA2102 error, as if i power off the SPA2102 then also i get this error. When i power off SPA2102 and check the status of peer(sip show peer peername) i see the status unreachable but asterisk still give me same error. If it is SPA2102 then asterisk should not give this error when peer is reachable.

Let me know what you think.

Thanks in advance.