The s extension [SOLVED]

I have few SIP trunks setup on my Asterisk 1.4 box. I treat them differently based on the DIDs in my incoming context. It looks like :

exten => 604288xxxx,1,NoOp(Incoming call from # ${CALLERID(num)} with SIP HEADER ${SIP_HEADER(FROM)})
exten => 604288xxxx,n,NoOp(SIP HEADER TO = ${SIP_HEADER(TO)})
exten => 604288xxxx,n,......    ;answer
exten => 778322xxxx,1,NoOp()
exten => 778322xxxx,n,......     ;doing something else

Now I am adding another SIP trunk from a different provider. The problem is now I have to use the s extension! If I use their DID Asterisk will tell me no extension found. I captured the sip header and I can see these info:

[quote]SIP HEADER FROM = sip:604582xxxx@208.xx.x.xx;tag=11014dd0-13c4-4bc4990a-b3f8c3c9-7e32f5a7
SIP HEADER TO = sip:8992xxxxx@208.xx.x.xx;transport=UDP

Generally I would like to avoid to use the s extension. Is there anyway to use their DID as extension to send the call to the proper context?

Please help and thanks a lot!

have you specify a specific REGISTER for this new SIP provider?
have a look here ->

and check the format for register definition:
register => user[:secret[]]@host[:port][/extension]

if you do not specify the extension it will go to “s”


Thanks. I missed this setting. Now it’s working! :smiley: