Temporary silence during call

We have some intermittent issues with audio going one-way only for a period of around 5 seconds during a call. It doesn’t happen every time and so far I’ve been unable to identify a pattern to which calls will be affected and which won’t, but when it does happen it seems to be a few seconds after the start of the call. So a call will be fine for a few seconds, one-way audio for 5 seconds, then fine for the rest of the call.

I’m at a loss where to start trying to isolate this. It happens on internal calls between extensions on the same system and on external calls going via a SIP trunk or ISDN line. We’ve got recordings of calls via MixMonitor which has all the two-way audio throughout but one or other of the extensions on the call have not been receiving any audio.

Any ideas what I could try next?

There might be plenty of reasons for such behaviour. Description tells that it is not related to the provider. So, two large categories of the failures are local network and Asterisk server.

First of all, is RTP traffic for internal calls going through Asterisk or directly between endpoints (directmedia=yes)?
In case of direct media, check logs from your network equipment - may be it gets congested or has a faulty interface. Do you have a LAN scheme? Does this fault happen for all the extensions or only for particular ones?

If RTP goes through Asterisk, reconfigure it temporary to direct media. Will this resolve the issue? If no - see above. If yes - check OS load and system logs on Asterisk server first.

But considering that it is a one-way audio, not a complete RTP loss, most likely cause is your network equipment.

I’m using directmedia=no for the moment in order to record calls within Asterisk. I’ll try changing it to yes and see if it has any impact.

Asterisk will re-INVITE back if you initiated recording, so you do not need to specify directmedia=no just to recordi.

So, change to directmedia=yes and see if the issue persists for internal calls.

But note that this test is only valid if the dialplan is compatible with direct media. E.g. enabling monitoring will disable direct media.

Thanks both, I’ve changed to directmedia=yes and disabled all monitoring and will let it run for a day or so to see how it goes!