TE110P not coming up [SOLVED]


#1

I have a TE110P installed in a Gentoo Linux server along with a TDM400 (2x FXS & 2x FXO). So far the analogue ports seem to be fine. But I’m having a problem with the digital interface.

My logs show the card has been found:

Module 0: Installed -- AUTO FXS/DPO Module 1: Installed -- AUTO FXS/DPO Module 2: Installed -- AUTO FXO (FCC mode) Module 3: Installed -- AUTO FXO (FCC mode) Found a Wildcard TDM: Wildcard TDM400P REV I (4 modules) ACPI: PCI Interrupt 0000:02:0b.0[A] -> Link [LNKH] -> GSI 11 (level, low) -> IRQ 11 ACPI: PCI Interrupt 0000:02:0d.0[A] -> Link [LNKF] -> GSI 7 (level, low) -> IRQ 7 Controller version: 24 FALC version: 00000000 TE110P: Setting up global serial parameters for E1 FALC V1.2 TE110P: Successfully initialized serial bus for card Found a Wildcard: Digium Wildcard TE110P T1/E1 TE110P: Span configured for CCS/HDB3 Calling startup (flags is 4099) wcte1xxp: Setting yellow alarm TE110P: Span configured for CCS/HDB3 Calling startup (flags is 4099) Registered tone zone 4 (United Kingdom) Registered tone zone 4 (United Kingdom)
Running ztcfg -vv shows everything seem to be fine too:

[code]Zaptel Configuration

SPAN 1: CAS/HDB3 Build-out: 0 db (CSU)/0-133 feet (DSX-1)

Channel map:

Channel 01: FXO Kewlstart (Default) (Slaves: 01)
Channel 02: FXO Kewlstart (Default) (Slaves: 02)
Channel 03: FXS Kewlstart (Default) (Slaves: 03)
Channel 04: FXS Kewlstart (Default) (Slaves: 04)
Channel 05: Individual Clear channel (Default) (Slaves: 05)
Channel 06: Individual Clear channel (Default) (Slaves: 06)
Channel 07: Individual Clear channel (Default) (Slaves: 07)
Channel 08: Individual Clear channel (Default) (Slaves: 08)
Channel 09: Individual Clear channel (Default) (Slaves: 09)
Channel 10: Individual Clear channel (Default) (Slaves: 10)
Channel 11: Individual Clear channel (Default) (Slaves: 11)
Channel 12: Individual Clear channel (Default) (Slaves: 12)
Channel 13: Individual Clear channel (Default) (Slaves: 13)
Channel 14: Individual Clear channel (Default) (Slaves: 14)
Channel 15: Individual Clear channel (Default) (Slaves: 15)
Channel 16: Individual Clear channel (Default) (Slaves: 16)
Channel 17: Individual Clear channel (Default) (Slaves: 17)
Channel 18: Individual Clear channel (Default) (Slaves: 18)
Channel 19: Individual Clear channel (Default) (Slaves: 19)
Channel 20: D-channel (Default) (Slaves: 20)
Channel 21: Individual Clear channel (Default) (Slaves: 21)
Channel 22: Individual Clear channel (Default) (Slaves: 22)
Channel 23: Individual Clear channel (Default) (Slaves: 23)
Channel 24: Individual Clear channel (Default) (Slaves: 24)
Channel 25: Individual Clear channel (Default) (Slaves: 25)
Channel 26: Individual Clear channel (Default) (Slaves: 26)
Channel 27: Individual Clear channel (Default) (Slaves: 27)
Channel 28: Individual Clear channel (Default) (Slaves: 28)
Channel 29: Individual Clear channel (Default) (Slaves: 29)
Channel 30: Individual Clear channel (Default) (Slaves: 30)
Channel 31: Individual Clear channel (Default) (Slaves: 31)
Channel 32: Individual Clear channel (Default) (Slaves: 32)
Channel 33: Individual Clear channel (Default) (Slaves: 33)
Channel 34: Individual Clear channel (Default) (Slaves: 34)
Channel 35: Individual Clear channel (Default) (Slaves: 35)

35 channels configured.[/code]
/etc/zaptel.conf looks as follows:

fxoks = 1-2 fxsks = 3-4 span = 1,1,0,cas,hdb3 bchan = 5-19,21-35 dchan = 20 loadzone = uk defaultzone = uk
…and the zapata.conf file contains:

[code][channels]

language = en
context = default
switchtype = euroisdn
priindication = outofband
usecallerid = yes
echocancel = yes
echocancelwhenbridged = yes
rxgain = 0.0
txgain = 0.0
; Specify whether the channel should be answered immediately or
; if the simple switch should provide dialtone, read digits, etc.
;
immediate = no
busycount = 4
musiconhold = default

signalling = fxo_ks
language = en
context = default
accountcode = PORT_1
group = 1
channel => 1

signalling = fxo_ks
language = en
context = default
accountcode = PORT_2
group = 2
channel => 2

signalling = fxs_ks
language = en
context = nokia
accountcode = PORT_3
group = 3
channel => 3

signalling = fxs_ks
language = en
context = nokia
accountcode = PORT_4
group = 3
channel => 4

switchtype = euroisdn
signalling = pri_cpe
faxdetect = both
context = default
group = 5
channel => 5-19,21-35[/code]
The problem is that connecting to my voice switch I get no lights on the TE110P card. My switch reports loss of framing at layer 1.

Checking zztool shows a red alarm, but IRQs are fine:

Current Alarms: Red Alarm x x Sync Source: Internally clocked x x IRQ Misses: 0 x x Bipolar Viol: 0 x x Tx/Rx Levels: 0/ 0 x x Total/Conf/Act: 31/ 31/ 0 x x 1111111111222222222333 lqqqqqqk x x 1234567890123456789012345789012 x Back x x x TxA ------------------------------- mqqqqqqj x x TxB ------------------------------- x x TxC ------------------------------- x x TxD ------------------------------- x x lqqqqqqk x x RxA ------------------------------- x Loop x x x RxB ------------------------------- mqqqqqqj x x RxC ------------------------------- x x RxD -------------------------------
Do I have to tell the TE110P card to come online somehow or am I missing something in the config here??


#2

Make your span for the T1, span 2 and not 1. Then change your bchannels to 32-46,48-62 and your dchannel to 47. Make the correct changes to zapata.conf also.


#3

Made the config changes, but that fails on ztcfg -vv:

[code]Zaptel Configuration

SPAN 1: CAS/HDB3 Build-out: 0 db (CSU)/0-133 feet (DSX-1)

Channel map:

Channel 01: FXO Kewlstart (Default) (Slaves: 01)
Channel 02: FXO Kewlstart (Default) (Slaves: 02)
Channel 03: FXS Kewlstart (Default) (Slaves: 03)
Channel 04: FXS Kewlstart (Default) (Slaves: 04)
Channel 32: Individual Clear channel (Default) (Slaves: 32)
Channel 33: Individual Clear channel (Default) (Slaves: 33)
Channel 34: Individual Clear channel (Default) (Slaves: 34)
Channel 35: Individual Clear channel (Default) (Slaves: 35)
Channel 36: Individual Clear channel (Default) (Slaves: 36)
Channel 37: Individual Clear channel (Default) (Slaves: 37)
Channel 38: Individual Clear channel (Default) (Slaves: 38)
Channel 39: Individual Clear channel (Default) (Slaves: 39)
Channel 40: Individual Clear channel (Default) (Slaves: 40)
Channel 41: Individual Clear channel (Default) (Slaves: 41)
Channel 42: Individual Clear channel (Default) (Slaves: 42)
Channel 43: Individual Clear channel (Default) (Slaves: 43)
Channel 44: Individual Clear channel (Default) (Slaves: 44)
Channel 45: Individual Clear channel (Default) (Slaves: 45)
Channel 46: Individual Clear channel (Default) (Slaves: 46)
Channel 47: D-channel (Default) (Slaves: 47)
Channel 48: Individual Clear channel (Default) (Slaves: 48)
Channel 49: Individual Clear channel (Default) (Slaves: 49)
Channel 50: Individual Clear channel (Default) (Slaves: 50)
Channel 51: Individual Clear channel (Default) (Slaves: 51)
Channel 52: Individual Clear channel (Default) (Slaves: 52)
Channel 53: Individual Clear channel (Default) (Slaves: 53)
Channel 54: Individual Clear channel (Default) (Slaves: 54)
Channel 55: Individual Clear channel (Default) (Slaves: 55)
Channel 56: Individual Clear channel (Default) (Slaves: 56)
Channel 57: Individual Clear channel (Default) (Slaves: 57)
Channel 58: Individual Clear channel (Default) (Slaves: 58)
Channel 59: Individual Clear channel (Default) (Slaves: 59)
Channel 60: Individual Clear channel (Default) (Slaves: 60)
Channel 61: Individual Clear channel (Default) (Slaves: 61)
Channel 62: Individual Clear channel (Default) (Slaves: 62)

35 channels configured.

ZT_CHANCONFIG failed on channel 36: No such device or address (6)[/code]


#4

Do you have your card set in E1 mode with the jumpers?


#5

Yes, it’s been changed to E1 prior to install.


#6

Try using a loopback plug and see if your alarms clear in zttool


#7

Took and RJ45 plug and looped pins 1&4 and 2&5. Inserted into card and zttool shows red alarm. No change.

Still no LED lighting up on the back of the card either.


#8

Sounds like you may have a bad card. I would remove the TDM400 and try it with just the T1 card and if it still doesnt green up call digium


#9

Also check if the card is taking interrupts.

cat /proc/interrupts

Look at the row with the wct4xxp driver and you see the big number incrementing about 1000/second


#10

Also make sure that you have it in the correct PCI slot, 3.3V and not a 5V slot. I had a similar problem on one of my boxes and I had to disable the onboard NIC and slot in a PCI NIC card.

When you boot up the machince is it detectecting the TE110P and asking to configure it?


#11

[quote=“angler”]Also check if the card is taking interrupts.

cat /proc/interrupts

Look at the row with the wct4xxp driver and you see the big number incrementing about 1000/second[/quote]

ipabx ~ # cat /proc/interrupts | grep wc 7: 247956139 XT-PIC wctdm, wcte11xp

Is incrementing…although am I seeing correctly that both cards are on IRQ 7??


#12

Will de-rack the box and try that.

No, just boots up, finds the card and starts it.


#13

Yes both cards are on that IRQ. If you cun the cat command twice over with a second pause or so between them, you should that it roughly increased by 2000


#14

Connected E1 card to another circuit and the line came up. Moved back to the old circuit…and then line came up.

Wierd.

But solved.