Tdm-400 + soekris 4801

Just been pointed over here from the soekris mailing list, thanks Darrick!

What I’m trying to do is to get the bleeding edge releases of dundi, asterisk, freepbx up and running on a soekris 4801, digium tdm-400, and wireless ( minipic atheros based ).

This is what I’ve got installed on a voyage linux ( kernel ) based platform:


I’ve successfully replaced the apache web server with lighttpd, and that’s working fine. I’m currently attempting to replace mysql with sqlite - which looks like it may be a bit of a failure… so freepbx and some of the recording stuff may just have to go, which is a shame ):

However, I’m having more basic problems. Although I’m booting to runlevel 2, and starting up
S99zasterisk ( link renamed to make it plum last! )

asterisk is running, but the FXS and FXO modules on the digium board are not enabled until I run a /etc/init.d/asterisk restart. The difference seems to be that the difference is that first time round, it’s starting up the dahdi_dummy module, whereas with a manual restart, wctdm and dahdi_ecocan_mg2 are in use. The confusing thing is that I modprobe for wctdm and dahdi in the rc.local - I’ve even tried starting asterisk after the modprobe and amportal start in /etc/init.d/rc.local. Do I need to test for the modules being loaded before starting asterisk ( the wctdm and dahdi_ecocan_mg2 aren’t loaded until asterisk is restarted )?? Confused.

The other thing I’m really short on is any documentation on how to start testing the installation: although I’ve been a *nix nerd for many many years, I’m a fair asterisk noob. For example, I don’t even know how to test if an extension is working! Could anyone point me in the right direction for that kind of stuff??

I’m currently running an old version of AAH on an old Dell desktop, and, apart from the power it’s using, it’s getting pretty hot in the roofspace this time of the year in godzone!

Cheers, Steve

A good book about * is here: , if you follow the “Online book” link you can get the pdf for free.


Marco Bruni

I wonder if your DAHDI problem is the same as the poster in this thread?

Perhaps there is a problem with the release of the DAHDI drivers?

Thanks Marco. I’ve read the first 75 pages already. Just what I needed!

Had a look at that thread, but I don’t think it’s the same dahdi problem: it’s not loading the correct modules - just the dummy. I don’t think you’ll see an error on the modules in that situation.

Try this one: