TCE400B card, mode=g729


#1

Hello all!

I just recentely bought TCE400B card to release some load on CPU. Its said having 3 modes supported in DAHDI config files.
mode=mixed/g729/g723 . I need to extend transcoding channels to 120 from 92. But this option doesn’t work

I added this to /etc/dahdi/init.conf as
mode=g729

Since this mode doesnt work, even dahdi wont start correctely.
With the default 92 channels I get this frequently, I need more channels.

[Aug 11 12:08:56] ERROR[1033]: codec_dahdi.c:416 dahdi_translate: Unable to attach to transcoder: Device or resource busy
[Aug 11 12:08:56] WARNING[1033]: translate.c:262 ast_translator_build_path: Failed to build translator step from alaw to unknown
[Aug 11 12:08:56] WARNING[1033]: channel.c:5709 ast_channel_make_compatible_helper: Unable to set read format on channel SIP/m9ast3-00073cc3 to slin

I searched thru mail lists, finding, that this problem was fixed some years ago, but for me it still persists.

I use * 1.8.5.0 and the latest rpm-based DAHDI 2.5.0
Linux avoip3 2.6.18-238.19.1.el5 #1 SMP Fri Jul 15 07:31:24 EDT 2011 x86_64 x86_64 x86_64 GNU/Linux


#2

Hello all!

After reading card installation manual, I made a try to use this option mode=g729 directly for module

modprobe wctc4xxp mode=g729 and it worked

The manual for this is not very obvouis although
Thank you.