[Solved] Realy bad audio quality


I’m having problems with my asterisk setup. I installed asterisknow on a vmware virtual pc and everything works fine until i connect to it with X-lite.
I set up a test extension which if being dialed, answers the call and plays a music (from the music-on-hold dir).
Problem is, the sound is really bad: it stops every few secs, audio degradation and its just… bad?

Any idea what could be the problem?

Asterisk is a realtime application and as such needs a fair amount of processing power. If your VM is even a little overpowered for the host things like this will happen. I used to have a test box running on a VM on my laptop and had the exact same issue, just too much for the laptop to handle.

Either try running the VM on a better host or install on a real PC (my test box is now on a 5 year old low end desktop pc and works fine).

Well, the host machine was a 3ghz p4 with 2 gb memory, and was idle at the time of testing.

But okay, i’ll try it on a real box.

Thanks for the tip, installing on a real pc solved the audio problems. Strange, since the host pc running the vmware server was more than enough for the task.

Its not so much the host not being up to the task its the nanosecond delays that vmware puts in there to handle the processes that cause issues. With most software no human would notice, with realtime voice your ear is very sensitive to those things.

VMware server is a great product (especially since its free) but no where near as good as ESX. My guess is (I havent tried this yet but its on my todo list) is Asterisk will run fine on ESX. My plan is to setup a HA solution and run my “hot spare” server on top of ESX