[SOLVED]No Audio without music on hold flag

I have an inbound number that I want to connect to my cell. The problem I’m having is that unless I use the music on hold flag, I don’t get any audio. For example:

exten => 1**********,1,Dial(SIP/1**********@flowroute,30,m)

The above works great, ot rings on my cell and the call is connected and we can talk. Now when I remove the music flag or try an ring flag because I need the ringing sound, it connects to my cell, but when I answer, all I get is silence:

exten => 1**********,1,Dial(SIP/1**********@flowroute,30)
exten => 1**********,1,Dial(SIP/1**********@flowroute,30,r)

Neither of the above works.

Anyone encountered this or have a fix?

[SOLVED] I added progressinband=yes to sip.conf under the general area. Now when I call with no flags, it rings and there is audio after I pick up.