[Solved-ish] Incoming calls drop after 15 minutes 30 seconds

I’m having a problem with incoming calls dropping after 15 minutes 30 seconds.

At 15 minutes, I receive an INVITE which appears to work properly. Then at 15 minutes 30 seconds I receive another INVITE, which states that the audio is at the IP address of the Asterisk server that sent me the call. This is incorrect, as up to this point the audio has been traveling to and from the carrier.

I’m running 11.7.0. The server that sends me the call is also running 11, but I am unsure which specific version. I have session-timers=refuse set, but that did not change anything. I’m apparently the only user with this problem.

If anyone could point me in the right direction for troubleshooting this, I would appreciate it.

I “solved” the problem by turning on my router’s SIP ALG. Now I receive the first INVITE but not the second one, and the call is uninterrupted.

If anyone has any insight into why this worked, I’m still curious. Thanks!