[SOLVED] incoming not working?

Hi,
I’ve setup Asterisk and have it working sucessfully with outgoing calls (I’m using Telepacket as my provider). Unfortunately, incoming calls are going straight to my voicemail on Telepacket. I ran the CLI and turned on sip debugging. When I called, I got the following. Help?

…dave

asterisk1*CLI>
<-- SIP read from 67.43.159.38:5060:
INVITE sip:s@24.95.62.160 SIP/2.0
Record-Route: sip:67.43.159.38;ftag=110FD308-2653;lr=on
Record-Route: sip:207.71.126.132;ftag=110FD308-2653;lr=on
Record-Route: sip:207.71.120.251;ftag=110FD308-2653;lr=on
Via: SIP/2.0/UDP 67.43.159.38;branch=z9hG4bK8a08.3dff39a99bb8c55cb05fab2739f0c4e7.0
Via: SIP/2.0/UDP 207.71.126.132;branch=z9hG4bK8a08.5d71a752.0
Via: SIP/2.0/UDP 207.71.120.251;branch=z9hG4bK8a08.eeaf2c61.0
Via: SIP/2.0/UDP 67.43.155.130:5060
From: sip:16144752185@67.43.155.130;tag=110FD308-2653
To: sip:16143408887@207.71.120.251
Call-ID: E6B4C03-5C8411DA-B3E5DE0F-241EC949@67.43.155.130
Supported: timer,100rel
Min-SE: 1800
Allow: INVITE, OPTIONS, BYE, CANCEL, ACK, PRACK, COMET, REFER, SUBSCRIBE, NOTIFY, INFO
CSeq: 101 INVITE
Max-Forwards: 3
Remote-Party-ID: sip:+16144752185@67.43.155.130;party=calling;screen=yes;privacy=off
Contact: sip:16144752185@67.43.155.130:5060
Expires: 600
Allow-Events: telephone-event
Content-Type: application/sdp
Content-Length: 377

v=0
o=CiscoSystemsSIP-GW-UserAgent 2120 5824 IN IP4 67.43.155.130
s=SIP Call
c=IN IP4 67.43.155.130
t=0 0
m=audio 18918 RTP/AVP 18 0 3 100 101
c=IN IP4 67.43.155.130
a=rtpmap:18 G729/8000
a=fmtp:18 annexb=no
a=rtpmap:0 PCMU/8000
a=rtpmap:3 GSM/8000
a=rtpmap:100 X-NSE/8000
a=fmtp:100 192-194
a=rtpmap:101 telephone-event/8000
a=fmtp:101 0-16
a=direction:active

— (22 headers 16 lines)—
Using INVITE request as basis request - E6B4C03-5C8411DA-B3E5DE0F-241EC949@67.43.155.130
Sending to 67.43.159.38 : 5060 (non-NAT)
Found peer 'telepacket-out’
Reliably Transmitting (no NAT) to 67.43.159.38:5060:
SIP/2.0 407 Proxy Authentication Required
Via: SIP/2.0/UDP 67.43.159.38;branch=z9hG4bK8a08.3dff39a99bb8c55cb05fab2739f0c4e7.0;received=67.43.159.38
Via: SIP/2.0/UDP 207.71.126.132;branch=z9hG4bK8a08.5d71a752.0
Via: SIP/2.0/UDP 207.71.120.251;branch=z9hG4bK8a08.eeaf2c61.0
Via: SIP/2.0/UDP 67.43.155.130:5060
From: sip:16144752185@67.43.155.130;tag=110FD308-2653
To: sip:16143408887@207.71.120.251;tag=as660251e7
Call-ID: E6B4C03-5C8411DA-B3E5DE0F-241EC949@67.43.155.130
CSeq: 101 INVITE
User-Agent: Asterisk PBX
Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER, SUBSCRIBE, NOTIFY
Max-Forwards: 70
Contact: sip:s@24.95.62.160
Proxy-Authenticate: Digest realm=“asterisk”, nonce="3039b13b"
Content-Length: 0


Scheduling destruction of call ‘E6B4C03-5C8411DA-B3E5DE0F-241EC949@67.43.155.130’ in 15000 ms
asterisk1*CLI>
<-- SIP read from 67.43.159.38:5060:
ACK sip:s@24.95.62.160 SIP/2.0
Via: SIP/2.0/UDP 67.43.159.38;branch=z9hG4bK8a08.3dff39a99bb8c55cb05fab2739f0c4e7.0
From: sip:16144752185@67.43.155.130;tag=110FD308-2653
Call-ID: E6B4C03-5C8411DA-B3E5DE0F-241EC949@67.43.155.130
To: sip:16143408887@207.71.120.251;tag=as660251e7
CSeq: 101 ACK
Content-Length: 0

— (7 headers 0 lines)—
asterisk1*CLI>
<-- SIP read from 67.43.159.38:5060:
OPTIONS sip:s@24.95.62.160 SIP/2.0
Via: SIP/2.0/UDP 67.43.159.38:5060;branch=0
From: sip:pinger@telepacket.com;tag=85f7c051
To: sip:s@24.95.62.160
Call-ID: 7d599364-24940686-87ee2@67.43.159.38
CSeq: 1 OPTIONS
Content-Length: 0

— (7 headers 0 lines)—
Looking for s in from-sip-external (domain 24.95.62.160)
Transmitting (no NAT) to 67.43.159.38:5060:
SIP/2.0 200 OK
Via: SIP/2.0/UDP 67.43.159.38:5060;branch=0;received=67.43.159.38
From: sip:pinger@telepacket.com;tag=85f7c051
To: sip:s@24.95.62.160;tag=as68e9218a
Call-ID: 7d599364-24940686-87ee2@67.43.159.38
CSeq: 1 OPTIONS
User-Agent: Asterisk PBX
Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER, SUBSCRIBE, NOTIFY
Max-Forwards: 70
Contact: sip:24.95.62.160
Accept: application/sdp
Content-Length: 0


Destroying call '7d599364-24940686-87ee2@67.43.159.38’
asterisk1CLI>
Destroying call 'E6B4C03-5C8411DA-B3E5DE0F-241EC949@67.43.155.130’
asterisk1
CLI>
[/code]

Do you have a 16143408887 extension in extensions.conf? Is it in the correct context?

Please see my reply to in this thread, forums.digium.com/viewtopic.php?t=2597, it should help you.

Regards.

Marco Bruni

Hi,
I got this fixed (before I saw your reply) by following the instructions at:

samyantoun.50webs.com/asterisk/a … allpacket/

Thanks anyway. :smile:

…dave