[SOLVED]Dialplan/extensions in realtime via ODBC(MariaDB)

Hi everybody,
I need to force asterisk for use database to read extensions/dialplan. For now Asterisk could read sippeers from realtime and for that it using this same DSN which I would like to use for extensions. So I assume it is not ODBC or mariadb connection (asterisk and MariaDB are two different hosts).

I still facing with ‘Call from ‘100’ (ip address:5060) to extension ‘start’ rejected because extension not found in context ‘vhz8xkn’.’. Of course i call to ‘start’ extension and mentioned context was set for my peer.

Have you defined your vhz8xkn context with start extension in your database? Does it have a priority 1?

Have you switched to your database with the switch statement in extensions.conf ?

Thank you for response. Yes, I add (http://i.share.pho.to/90fe40ff_o.png) contenet to database, also in my extensions.conf add

[vhz8xkn]
switch => Realtime

And now I have no idea what is wrong with that.
Database dump

"id_firma",“context”,“exten”,“priority”,“app”,“appdata”
“1”,“vhz8xkn”,“start”,“1”,“noop”,“Startuje z programem ${CONTEXT}”
“1”,“vhz8xkn”,“start”,“2”,“playback”,"${IDFIRMA}/${CHANNEL(language)}/hv67t188dv75i2x"
“1”,“vhz8xkn”,“start”,“3”,“goto”,“vhz8xkn-gva2,start,1"
“1”,“vhz8xkn”,“start”,“4”,“noop”,“nowyGraf”
“1”,“vhz8xkn-gva2”,“start”,“1”,“noop”,“vhz8xkn-gva2,start”
“1”,“vhz8xkn-gva2”,“start”,“2”,“background”,”${IDFIRMA}/${CHANNEL(language)}/hv67t188dv75i2x"
“1”,“vhz8xkn-gva2”,“start”,“3”,“waitexten”,“4”

Your schema looks off with an ‘id_firma’ field where I just have one called ‘id’ and the entries are unique in that column where yours are duplicated.

I’d try changing your column name and making the entries unique.

Do you have an extensions entry in your extconfig.conf that’s pointing to your database?

Nope. I added ‘id’ column with primary index, but it didnt solved my problem. By the way ‘id_firma’ it means ‘id_company’.
EDIT: Yes, I wrote to extconfig.conf

[settings]
queues=>odbc,asterisk,voice_queue
queue_members=>odbc,asterisk,voice_agenci
extensions=>odbc,asterisk,voice_dialplan
sippeers=>odbc,asterisk,voice_konta

and your table is defined as voice_dialplan in your database?

If you do a ‘dialplan show vhz8xkn’ at the console do you see the realtime switch?

voip01*CLI> dialplan show vhz8xkn

[ Context ‘vhz8xkn’ created by ‘pbx_config’ ]
Alt. Switch => ‘Realtime/’ [pbx_config]

-= 0 extensions (0 priorities) in 1 context. =-
voip01*CLI>


EDIT: Yes, table which has extensions content is voice_dialplan

Ok. I found where the problem is, so in a fact I used ekiga sip client instead any other. I dont know why asterisk has a problem with invite from that ones but after change to another softphone everything goes fine. I realize now i have to rewrite my platform to generate dialplan into file instead database.