sjPhone and setting caller id

I am using and sjphone and asterisk. I traced the sip messages going in to asterisk and out from asterisk to For some reason, I cannot get the caller id to get set at all.


  1. Can I set up sjphone/asterisk to register as extension 6000 and then call out with caller id XXX-XXX-XXXX
  2. Is there a better softphone I can use with asterisk that will do what I want when SjPhone can’t?[/quote]

Here is what I see in the trace
Invite from sjphone to asterisk has From as 6000@
Invite from asterisk to has From as asterisk@

so obviously my callerid is not working as asterisk is inserting asterisk instead of the phone number. How do I set this up? When I change sjphone’s caller id, registration with asterisk stops working.

Caller-ID is just a field in a header than can easily be set by the device owner… I wouldn’t rely on it for making dialplan decisions. Have a look at ANI and DNID.

As for setting your caller id in Asterisk, it’s easy…

Well, actually, I figure if I can do it in SjPhone, I can do it in my sip stack. We need to set the caller id of an end user to send a voice message to his friend through our system. We use extension 6000 for example but want the caller id to be that of the customer, not a single phone number(since that is who is really sending you the message). The problem is that asterisk is NOT passing the Sip Invite From phone number through the system properly for some reason. It translates the user from 303-xxx-xxxx to ‘asterisk’ and I don’t know why.

I do not have the option of setting the extension to a single number. It changes every time a phone call is placed outbound depending on which customer caused the outbound call. There should be a way in sjphone to set the caller id so asterisk does not translate it to asterisk@< ip> which is very annoying. Isn’t there some trivial setting somewhere were I can tell asterisk to quit doing that and send the XXXXXXXXXX@< ip> that I want from the invite I sent to begin with?

All my SIP caller ids are sent fine through asterisk and I didn’t have to tweak anything for this behavior. Maybe your SjPhone is the problem. What happens if you just stick Verbose(${CALLERID(all)}) in your SIP phone extension?