SIP URI Call Test not working

Hi!
I installed asterisk and now I tried to configure that. I use Asterisk 20 mit PJSIP.
I want to call SIP URIs directly. I found some test SIP URIs, now I’m unsure if I have something wrong or if the SIP URIs doesn’t work.

My Log:

    -- Executing [200@from-internal:1] Answer("PJSIP/6001-00000013", "") in new stack
       > 0x7882ec047910 -- Strict RTP learning after remote address set to: 10.0.3.120:52616
    -- Executing [200@from-internal:2] Wait("PJSIP/6001-00000013", "1") in new stack
       > 0x7882ec047910 -- Strict RTP switching to RTP target address 10.0.3.120:52616 as source
    -- Executing [200@from-internal:3] Dial("PJSIP/6001-00000013", "PJSIP/mytrunk/sip:thetestcall@sip.linphone.org,30") in new stack
    -- Called PJSIP/mytrunk/sip:thetestcall@sip.linphone.org
    -- PJSIP/6001-00000013 requested media update control 26, passing it to PJSIP/mytrunk-00000014
  == Everyone is busy/congested at this time (1:0/1/0)
    -- Executing [200@from-internal:4] Hangup("PJSIP/6001-00000013", "") in new stack

I tried the following SIP URIs:

thetestcall@sip.linphone.org
lenny@incrediblepbx-2020-cac.wardmundy.net
music@iptel.org
test.time@sip5060.net

none is working.

Here my pjsip.conf:

[transport-udp]
type=transport
protocol=udp
bind=0.0.0.0

[transport-tcp]
type=transport
protocol=tcp
bind=0.0.0.0

[6001]
type=endpoint
context=from-internal
disallow=all
allow=ulaw
auth=6001
aors=6001

[6001]
type=auth
auth_type=userpass
password=unsecurepassword
username=6001

[6001]
type=aor
max_contacts=1

[mytrunk]
type=endpoint
disallow=all
allow=ulaw
allow=g722

and my extensions.conf:

[from-internal]
exten = 100,1,Answer()
same = n,Wait(1)
same = n,Playback(hello-world)
same = n,Hangup()

exten = 200,1,Answer();
same = n,Wait(1)
same = n,Dial(PJSIP/mytrunk/sip:thetestcall@sip.linphone.org,30)
same = n,Hangup()

You need to enable protocol logging with “pjsip set logger on”.

Also please use the full log file, not a screen scrape, so that the log includes time stamps.

It looks like the call was rejected by the remote end, as I don’t think it would report the media update if it had rejected immediately.

Although you an call an endpoint anything you like if you don’t need to identify it by name, trunk implies multiple circuits to one place, but you actually have multiple circuits to anywhere on the internet.

Hi!

Thank you for your answer. I found the mytrunk info in this forum (PJSIP: Dial a SIP-URI?) but the link in the wiki was dead.
Did you have some idea what I can try to change?

Now I created a log:
full.txt (82.7 KB)

[2024-07-06 23:23:33.994] DEBUG[144874] res_pjsip_session.c: PJSIP/mytrunk-0000002e: Source of transaction state change is TRANSPORT_ERROR

My guess is that it failed to resolve the address or failed to find a route to that address, but it isn’t being specific.

[2024-07-06 23:23:33.994] DEBUG[143651] res_pjsip/pjsip_resolver.c: [0x7882e0031ec8] Resolution completed - 0 viable targets

It does look like a DNS name resolution problem.

Thank you for your help. Doesn’t know what was the problem. After reboot of the system it is working!