SIP trunk with using port other than 5060

Whenever I try to use a port other than 5060 (like 5062) in sip trunks the calls fail.
I tried using the “port=5062” parameter in the trunk configuration, if there anything else I should do?

Asterisk version

Can you explain what are you trying to accomplish ?
I do not think the port parameter does what you think it does.
You must be thinking about udpbindaddr, more info

I have three boxes running asterisk, one as a SIP-to-TDM gateway for two other as PBX. The two PBX use port 5060 for SIP trunking with the SIP-to-TDM but I want one of them to use 5062 instead. Isn’t that what the “port” parameter does?

No, just because you see “port” it does not mean this the thing you are looking for.