SIP to SIP audio problem


#1

I have 2 Grandstream GXP2000 phones and a remote user using the Xlite softphone. When calling between the SIP phones, we can’t hear each other. I also have an analog phone plugged into a digium card and if I use it, we can hear each other. Is there something I’m missing in my config to allow SIP to SIP calls?

extensions.conf:

[incoming]
exten => s,1,Wait(1)
exten => s,2,Dial(Zap/1|20,t)
exten => s,3,Voicemail,u1000
exten => s,4,Hangup
exten => s,103,Voicemail,b1000
exten => s,104,Hangup

[internal]
include => outbound-local
include => outbound-long-distance

exten => 1000,1,Dial,Zap/1|20
exten => 1000,2,Voicemail,u1000
exten => 1000,3,Hangup
exten => 1000,102,Voicemail,b1000
exten => 1000,103,Hangup

exten => 1212,1,Dial(SIP/phone1)
exten => 1212,2,Voicemail,u1212
exten => 1212,3,Hangup
exten => 1212,102,Voicemail,b1212
exten => 1212,103,Hangup

exten => 1811,1,Dial(SIP/phone2)
exten => 1811,2,Voicemail,u1811
exten => 1811,3,Hangup
exten => 1811,102,Voicemail,b1811
exten => 1811,103,Hangup

exten => 1789,1,Dial(SIP/phone3)
exten => 1789,2,Voicemail,u1789
exten => 1789,3,Hangup
exten => 1789,102,Voicemail,b1789
exten => 1789,103,Hangup

sip.conf:

[general]
context=default
srvlookup=yes

;Grandstream GX2000
[phone1]
type=friend
secret=XXXX
qualify=yes
nat=no
host=dynamic
canreinvite=no
context=internal

;Grandstream GX2000
[phone2]
type=friend
secret=XXXX
qualify=yes
nat=no
host=dynamic
canreinvite=no
context=internal

;X-Lite softphone
[phone3]
type=friend
secret=XXXX
qualify=yes
nat=no
host=dynamic
canreinvite=no
context=internal

any help would be greatly appreciated!!!


#2

Check in sip.conf you have local network defined properly

rgds


#3

i added the following to [general] in sip.conf:

localnet= ipaddress/subnet

still not working. could it be that the sip phones are not registering? Also, can’t call them with “host=dyanmic”, i have to type in the IP address of the phone.

any other ideas???


#4

Upon further investigation, I found that the person who installed FC4 had selinux enabled. After disabling selinux, calls sip to sip worked great.