SIP Peer Unspecified


I’m getting some peers showing as Unspecified in the CLI.

255/255 (Unspecified) D Auto (No) No A 0 Unmonitored

This is happening intermittently to numerous peers. Sometimes they are ok, sometimes they are like this. When they are ‘Unspecified’ they won’t accept calls, but can call out.

Trying to dial an extension in this state results in:

Unable to create channel of type 'SIP' (cause 20 - Subscriber absent)

The sip.conf for this is:


All the peers have the same options configured in sip.conf, yet most are online all the time.

I’ve tried a sip set debug ip ipaddress but it doesn’t show any errors. The handsets are Cisco SPA504G.

Any help greatly appreciated,



it seems phones are not renewing the registration. I had this same issue with Grandstream phones and it was solved after a firmware update.

I’m already using the latest firmware on all the phones.

This is what appears in the CLI when the state changes:

== Extension Changed 255[springfield] new state Unavailable for Notify User 550

and then (some time later…)

   -- Registered SIP '255' at
  == Extension Changed 255[springfield] new state Idle for Notify User 550

That is completely consistent with the explanation already given.

This sounds very much like
What Asterisk version are you on?
Does it mostly happen with the Cisco handsets that have more than one line configured?

Asterisk version 13.6.0

No, Cisco handsets but with only one line configured.

I’ve downgraded the firmware on the SPA504Gs from 7.6.1 to 7.5.7s and it seems to have solved the problem. For now at least, I will need to keep monitoring it.

Thanks for you help.

That bug above is present in that version of Asterisk.
I’m pretty sure you will continue to have this problem intermittently until you upgrade Asterisk.