SIP Packet Message Header

My provider says that I need to have my message header to have my DNS name not my IP address. when I do a packet capture the sip message header says VIA:

SIP/2.0/UDP MY-IP-ADDRESS; branch=some-weird-string;rport

Sent-by Address: MY-IP-ADDRESS
Sent-by port" 5060
branch some-weird-string
RPORT: rport

Via: SIP/2.0/UDP my-ip-address:5060;branch=z9hG4bK46745fe1;rport
From: “103” sip:user@my-ip-address;tag=as2e6c0950
To: sip:numberIamCalling@sip-ip-address;tag=aprqngfrt-su4s5c10000c6
Contact: sip:username@my-ip-address
Call-ID: 5570a442212e3ca873528a4326b287a7@my-ip-address
CSeq: 102 ACK
User-Agent: Asterisk PBX
Max-Forwards: 70
Content-Length: 0

Asterisk 1.4.23.1
FreePBX 2.5.1.5

Distributor ID: Ubuntu
Description: Ubuntu 8.10
Release: 8.10
Codename: intrepid

There is a “fromdomain” attribute you can set in your sip.conf. You can either set it in the [general] settings or in the trunk specific settings.