Sip maximum retry exeeded can't write frame

I installed astersik 1…4.2 and I have a prolem with sip phone asterisk drop the call after 20 second and it say

WARNING[4057]: chan_sip.c:1897 retrans_pkt: Maximum retries exceeded on transmission 866b2807350f6a63Mzc1ZWZkOWEzNjhiMDk4MDM3YjVmZjg0MTYxZmM3ZjE. for seqno 2 (Critical Response)
[Apr 18 13:32:21] WARNING[4057]: chan_sip.c:1914 retrans_pkt: Hanging up call 866b2807350f6a63Mzc1ZWZkOWEzNjhiMDk4MDM3YjVmZjg0MTYxZmM3ZjE. - no reply to our critical packet.

and also this problem

WARNING[15509]: file.c:616 ast_readaudio_callback: Failed to write frame

Can you tell me which soft phone you are using.


Thank you for reply I tried many times and no one answer me, about the sip phones you can say I used all of them xlite and what ever I found in the internet.
I found some thing in the internet that after asterisk 1.2.13 this problem start and is in the file chan_sip.c but I stop my asterisk 1.2.17 and I installed 1.2.13 and the problem still and also with 1.4.2.

    when usign hard phone like grandstream wich they are also sip phones there is no problem is only with xlite (web sip phone)

Please if you know any idea let me know

Try for the following ones.

In your sip.conf settings set


and for xten make sure silence suppression is turned off.

It may help you .


I added the tow cammnad but still the same problem

but how you make xten ( you mean x-lite) in silence suppression is turned off.

Try this url … tarted.pdf