SIP.conf TLSbindaddr=0.0.0.0

I want to config tls so I opened the sip.conf and entered / before I generated the certificates

tlsenable=yes
tlsbindaddr=0.0.0.0:5061
tlscertfile=/home/pi/certs/raspberrypi.pem
tlscafile=/home/pi/ca/InnovateAsterisk-Root-CA.crt

then I restart asterisk service

I can’t find the port 5061,
What I’m doing wrong??

root@raspberrypi:/home/pi# netstat -tulpn
Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
tcp 0 0 0.0.0.0:22 0.0.0.0:* LISTEN 693/sshd
tcp 0 0 0.0.0.0:4443 0.0.0.0:* LISTEN 1303/asterisk
tcp 0 0 0.0.0.0:445 0.0.0.0:* LISTEN 715/smbd
tcp 0 0 0.0.0.0:139 0.0.0.0:* LISTEN 715/smbd
tcp6 0 0 :::22 :::* LISTEN 693/sshd
tcp6 0 0 :::445 :::* LISTEN 715/smbd
tcp6 0 0 :::139 :::* LISTEN 715/smbd
udp 0 0 0.0.0.0:68 0.0.0.0:* 556/dhclient
udp 0 0 0.0.0.0:68 0.0.0.0:* 302/dhclient
udp 0 0 0.0.0.0:45687 0.0.0.0:* 1303/asterisk
udp 0 0 10.0.0.255:137 0.0.0.0:* 687/nmbd
udp 0 0 10.0.0.16:137 0.0.0.0:* 687/nmbd
udp 0 0 192.168.0.255:137 0.0.0.0:* 687/nmbd
udp 0 0 192.168.0.1:137 0.0.0.0:* 687/nmbd
udp 0 0 0.0.0.0:137 0.0.0.0:* 687/nmbd
udp 0 0 10.0.0.255:138 0.0.0.0:* 687/nmbd
udp 0 0 10.0.0.16:138 0.0.0.0:* 687/nmbd
udp 0 0 192.168.0.255:138 0.0.0.0:* 687/nmbd
udp 0 0 192.168.0.1:138 0.0.0.0:* 687/nmbd
udp 0 0 0.0.0.0:138 0.0.0.0:* 687/nmbd
udp 0 0 0.0.0.0:5353 0.0.0.0:* 309/avahi-daemon: r
udp 0 0 0.0.0.0:39244 0.0.0.0:* 309/avahi-daemon: r
udp 0 0 0.0.0.0:5060 0.0.0.0:* 1303/asterisk
udp6 0 0 :::5353 :::* 309/avahi-daemon: r
udp6 0 0 :::57680 :::* 1303/asterisk
udp6 0 0 :::52595 :::* 309/avahi-daemon: r

Is the chan_sip module loaded in Asterisk? Did it output an error or warning message on the console at start?

I don’t know if its loaded, I only changed the sip.conf
my modules.conf should be default

i followed this tutorial

Are you using a cert version? Those have chan_sip disabled by default, as they are intended for people with Sangoma support contracts, and chan_sip is no longer supported.

Is there a reason for not using chan_pjsip?

You can test if a module is loaded, by trying to load it from the CLI, which will tell you why it failed to load, if that wasn’t because of modules.conf

Is there a reason for not using sip?

I have only the pjsip.conf

Thats my version
Connected to Asterisk 16.2.1~dfsg-1+deb10u1 currently running on raspberrypi (pid = 1217)

The topic title says you are using sip.conf, not pjsip.conf.

The reason for not using chan_sip is that it is being phased out and only has community support, so bugs may not get fixed or may take a long time to fix.

ahhh
chan_sip = sip.conf
chan_pjsip = pjsip.conf

I’m using the phonelite softphone

so there are differences between the tls config: the sip.conf needs
tlsenable=yes
tlsbindaddr=0.0.0.0:5061
tlscertfile=/home/pi/certs/raspberrypi.pem
tlscafile=/home/pi/ca/InnovateAsterisk-Root-CA.crt

[transport-tls]
type=transport
protocol=tls
bind=0.0.0.0
cert_file=/home/pi/certs/raspberrypi.crt
priv_key_file=/home/pi/certs/raspberrypi.key
;cipher=ADH-AES256-SHA,ADH-AES128-SHA
method=tlsv1

[user3] ; user3@192.168.0.1:5061 TelNo: 300
type=friend
context=from-my-phones
secret=1234
host=dynamic
dtmfmode=rfc2833
disallow=all
allow=ulaw
allow=alaw
encryption=yes
transport=tls

type=transport can only appear in pjsip.conf!

The transport-tls section will be effectively ignored in sip.conf, as all the options are only valid in the general section, and transport is not a valid value for type.

1 Like

Ok I’ll try pjsip, I found the documentation

thank you for your help :+1:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.