SIP - call time limitation

Hi everyone,

I set the time limitation to 300 seconds for my SIP outboud calls. I recorded a 307 seconds call today. My VoIP provider also recorded it as a 307 seconds call.

the 300 seconds limitations has always worked fine… until today… Is there a way to fix this problem ? Accuracy is very important for my application.

Thank you very much.


give more info.

Such as what version of Asterisk? What setting or variable are you using to specify a limit?

In that it worked until today, what has changed that may have resulted in it no longer working.

Hi Mazzic,

Thank you for your reply. So, the Asterisk version is 1.8.1

Here is the dial command I use :

exten => _X.,n,dial(SIP/${ext}@ipoftheprovider,300,L( ${TimeLimit}[:15000][:7500]),tgh)

It’s has always worked perfectly except 2 days ago. I got a record with 7 seconds above the timelimit. It can’t be the “tgh” parameters ?



has something changed?

This line doesn’t look valid to me. The tgh is after another comma. Which puts it into the URL paramter. Also the [] are on the line which I don’t believe belong there. In the examples that is usually to indicate an optional value, but when you code the options you don’t include the brackets.

I’d expect the line to look like this…

exten => _X.,n,dial(SIP/${ext}@ipoftheprovider,300,L( ${TimeLimit}:15000:7500)tgh)