Simple Question on Zap channel instance


#1

Greetings,

This is my first post in this forum and I’ve just started to dabble with asterisk@home since 2 weeks ago, so pls forgive me for my shortcomings.

Just to let you guys know what I’ve done so far, I am using a TDM400 ( 1 FXO and 1 FXS, which i presume would make it a TDM11). However, I am currently using 1 channel only, which is loaded with a FXS device. I called it ZAP/1. I’ve also configured 2 SIP channels, SIP/1001 and SIP/1002. All channels are for internal use, and I haven’t configured PSTN connections yet. I am planning to add another ZAP channel, but I have to clarify some matters first.

Right now, I just need some clarification on the instance of the ZAP/1 channel. I’ve come to understand one zap channel can have 3 instances.

So what is the use of this instance?
Can I make use of this instance ( eg. ZAP/1-2 ) instead of creating a new ZAP channel?
If I can’t do that, then is it possible for me to forward the call immediately from ZAP/1-2 to ZAP/2-1?
Is there any way I can disable the Zap channels from automatically redirecting the incoming calls to ZAP/1-2 when the line is in use? Meaning I will get a busy tone, instead of a ringing tone.

Thanks in advance for your assistance. It would be great if you can provide me some links for further readings on this issue. I did not get much help from voip-info.org regarding this matter.

Cheers,
Yuvan


#2

As I understand it, the ‘instances’ are used for call waiting and other such things. I don’t know if you can address an instance directly, but I’m not sure you’d want to or that it would serve any functional purpose.

Remember, zap channels on a TDM card are analog- there can only be ONE audio stream going across a channel at a time (unlike SIP where you can have several active channels on one SIP account).


#3

Yes indeed…I completely forgot abt that, thanks for pointing it out. I am beginning to understand the use of the channel instances.
However, I am actually trying to write up a small switchboard program which doesn’t use any groups or voicemail. This would mean all my calls to Zap1 will be unattended if the channel is in use. Is there a way to forward the call immediately to Zap/2-1 instead of getting connected to Zap/1-2? In other words, can i disable the second and third instances of a Zap channel?


#4

callwaiting=no in zapata.conf? its something like that…


#5

Ok, i’ve tried messing around with the configuration files, and I am still clueless. I am attaching my zapata.conf and zapata_additional.conf and hopefully you can tell me where I am going wrong. I do apologize if the problem is very trivial, I am still learning abt Asterisk. Btw, I’m using Asterisk Management Portal to edit the conf files.

******** zapata.conf ******************
;
; Zapata telephony interface
;
; Configuration file

[trunkgroups]

[channels]

language=en
context=from-pstn
signalling=fxs_ks
rxwink=300 ; Atlas seems to use long (250ms) winks
;
; Whether or not to do distinctive ring detection on FXO lines
;
;usedistinctiveringdetection=yes

usecallerid=yes
hidecallerid=no
callwaiting=no
usecallingpres=yes
callwaitingcallerid=no
threewaycalling=no
transfer=yes
cancallforward=yes
callreturn=yes
echocancel=yes
echocancelwhenbridged=no
echotraining=800
rxgain=0.0
txgain=0.0
group=1
callgroup=1
pickupgroup=1
immediate=no

;faxdetect=both
faxdetect=incoming
;faxdetect=outgoing
;faxdetect=no

;Include genzaptelconf configs
#include zapata-auto.conf

;Include AMP configs
#include zapata_additional.conf

******** zapata_additional.conf **************
;;;;;;[1000]
signalling=fxo_ks
record_out=Always
record_in=Always
mailbox=
echotraining=800
echocancelwhenbridge=no
echocancel=yes
context=from-internal
callprogress=no
callerid=“Server” <1000>
busydetect=yes
busycount=7
channel=>1


#6

OK, let me rephrase the problem again. Hopefully its not so vague anymore.
Lets say I call channel Zap/1 using SIP/1. While I am talking to channel Zap/1-1, someone else calls channel Zap/1 too. This will lead to me hearing a call waiting tone on the Zap phone. I want the Zap phone to indicate its busy, not wait for calls. How do i disable this? I have tried to change the values of call waiting, busy detect and so on. Perhaps i am missing something out. Pls help. Thanks!


#7

what about zapata_auto.conf? also in the other file, explicitly define callwaiting=no… see if that does anything


#8

Well, I have tried callwaiting=no and busydetect=yes in zapata-auto, zapata and zapata-additional, but there is still no difference. For the time being, I think i will programmatically detect zap/1-2 and forward it to zap/2-1. I will try to figure out the problem and let you know why i can’t disable call waiting for zap. Thanks a lot for your help Iron, really appreciate it!


#9

RESOLVED

As i said earlier, it was a newbie mistake. I did not make changes to zapata-additional.conf in the right place. I did not put it under the right context. I should have added

callwaiting=no
threewaycalling=no
transfer=no

at context=from-internal. All this while i was making changes to the values at context=from-pstn. Got the answer while i was reading up on context.