Setting contact header

Sorry, if this question has been asked before, but I don’t see the solution.

I just installed Asterisk with FreePBX for the first time. Everything works, but I keep getting the following error message from the console.


<--- Received SIP request (331 bytes) from UDP:192.168.192.95:5160 --->
NOTIFY sip:192.168.192.86:5060 SIP/2.0
v: SIP/2.0/UDP 192.168.192.95:5160;branch=z9hG4bK-9d4c1150
f: xxxxx<sip:701@192.168.192.86:5060>;tag=dcb4ce23d31c835bo0
t: <sip:192.168.192.86:5060>
i: 5b395f43-6cec24bb@192.168.192.95
CSeq: 222 NOTIFY
Max-Forwards: 70
o: keep-alive
User-Agent: Linksys/PAP2T-5.1.6(LS)
l: 0


<--- Transmitting SIP response (354 bytes) to UDP:192.168.192.95:5160 --->
SIP/2.0 400 Missing Contact header
Via: SIP/2.0/UDP 192.168.192.95:5160;received=192.168.192.95;branch=z9hG4bK-9d4c1150
Call-ID: 5b395f43-6cec24bb@192.168.192.95
From: "XXXXXX" <sip:701@192.168.192.86>;tag=dcb4ce23d31c835bo0
To: <sip:192.168.192.86>;tag=z9hG4bK-9d4c1150
CSeq: 222 NOTIFY
Server: FPBX-14.0.3.13(13.99.99)
Content-Length:  0

…95 is a Cisco PAP2T. All other devices in the system behave correctly. I cannot find the ‘Missing Contact Header’ it refers to; and am unsure of the value that should be applied to it when I find it, which is causing the 400 error.

Can someone point me to the right direction, so I can resolve this repeating error message?

Since it’s using short header names it would be an “m” header which is indeed missing. There’s nothing you can do on the Asterisk side to stop this, and it doesn’t really matter to Asterisk as we don’t accept NOTIFY packets like that.

Thanks for the quick response. Much appreciated.

Unless someone who knows more than me can chime in, I will assume there is no way to fix the contact header issue from the Cisco PAP2T side either. I do not see a setting in the ATA that will address that issue either?

Best.