Setting auto-answer using SIP Header on Zoiper soft-phone

I’m running the Zoiper Biz 2.35 softphone on Windows, connected on the local network to Asterisk 1.6.2.13.

What I’m trying to do is get Zoiper to automatically pick-up an incoming call by adding a SIP Header.

I have set the “Accept server-side auto answer” option in the Zoiper settings and have tried using a dialplan with a couple of different SIPAddHeader options but Zoiper will not automatically answer the call (unless, of course, I manually set it to do so on the Zoiper interface).

I am fairly new to Asterisk, so any support is appreciated. This is the dialplan I have tried unsuccessfully:
[zoiperautopickup]
exten => s,1,SIPAddHeader(Call Info: Answer-After=0)
exten => s,n,SIPAddHeader(Alert-Info: info=alert-autoanswer)
exten => s,n,Dial(DAHDI/g0/0212341234,20)

This calls the Zoiper phone and waits be picked up before making the outgoing call. I was hoping it would automatically answer the Zoiper phone and then make the outgoing call (so I don’t need to do anything).

If anyone had experience or guidance on how to get the Zoiper softphone to auto-answer, without manually setting it to do so on the Zoiper interface, your help would be greatly appreciated.

Thanks,
Mark

Howdy,

That dialplan snippet doesn’t involve a SIP channel, I don’t see where Zoiper could be involved. In that, you’re dialing out a DAHDI channel.

@malcolmd,

How can we do that.Please explain the process.

  1. What all to include in AMI SIP packet
  2. what changes i need to make in my asterisk dialplan.
  3. what all need to check in SIP trace (i am using sngrep to check SIP trace).
  4. how to make a successfull test.
1 Like

This is an 8-year old thread. No thank you.

  1. There is no such thing.
  2. What is your dialplan? We can’t tell you what to change if we don’t know the starting point (and are more likely to tell you what is wrong, anyway).
  3. The header you are trying add.
  4. A successful test is when the phone auto-answers.

And, as Malcolm says, this thread is ancient, so the answers may have changed, anyway. Also the original poster has not responded to the obvious error that was pointed out, at the time.