Segmentation fault after running asterisk 1.*

asterisk print these messages after trying to run it( all version 1.4 ->

No entry for terminal type "linux"; using dumb terminal settings. Segmentation fault

I found that the first two messages are from ./main/editline/term.c

but I don’t know how to fix this, I tried some solution from the internet but the problem still the same.

Segmentation faults at start up are usually due to having incompatible modules in the Asterisk modules directory, e.g. through not removing old ones when installing a new version.

If it is not a secondary error, the “lack of information” message suggests a faulty operating system installation. You have told us nothing about that.

Otherwise, google “asterisk wiki backtrace” and provide all the information that asks you to gather, but only for

I was able to fix the first two messages by putting the cross-compiled ncurses in the rootfs of my linux and then build linux kernel.
but the problem of segmentation fault still, when I tried to start asterisk with “asterisk -cg” the message that appear was “segmentation fault (core dump)”.
I don’t know what is the problem with it?

Nor do we, and you haven’t provided the requested information that might give us a clue.