RTP want pass throught the router

Hi,

I’m trying get a working Asterisk instance but right now I see RTP flow to proper IP address which is my home router (asterisk is in the Internet and hide on another router) but RTP want across my home router. What could be the issue ?

If you need configuration then just ask.

please check if sip alg is active in router

disable it if yes

On both site is Mikrotik and yes i disabled it

try using sngrep -r --rtp: Capture RTP packets payload

to diagnose

If you are trying to get two Asterisk boxes to talk to each other, and you don’t need any SIP-specific features, then you might test out Inter-Asterisk-eXchange (IAX) protocol instead. Since IAX only requires a single UDP port, there’s a lot less your firewalls need to worry about, compared to SIP/RTP.

Also, if you’ve got the same model router on each side, then a site-to-site VPN is another good option; the VoiP traffic can tunnel over the VPN and stop bothering so many of your routers’ rules regarding RTP streams.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.