*RESOLVED*Call to Chrome fails:603 Failed to get local SDP

Greetings all,

I have been struggling with this for a while now, so I am hoping someone can give me some advice.

I am trying to setup a WEBRTC capable Asterisk server that will allow calls via Chrome only within our Internal network.

I’ve got it setup and working where calls work from Browser -> Softphone (X-Lite) and Softphone -> Softphone.

The problem is when we try to make a call to the browser, upon accepting permission to use the MIC, the browser produces a “Call Rejected” message.

On the Asterisk logging it shows: Failed to get local SDP

Can anyone point me in the right direction? Thanks!

Asterisk Debugging shows this:

Show us the sip debug of asterisk without cli DEBUG and also the JS log from chrome.

How’s this?

WITHOUT CLI DEBUG!!! only sip debug enabled your debug have a lot of garbage.

Ok I edited the Log post above with CLI Debug off. Thanks for any insights

That came from the JS log, how is your webrtc config? Did you enable the secure=yes, icesupport=yes and avpf=yes?

Did you compiled the srtp library before install asterisk?

Thanks - your comment helped resolve the issue.

I had encryption=yes in sip.conf but I had to add it to each extension as well.

I am now able to receive a call in the browser. Thanks for your help

I was following tutorial at sipml5.org/call.htm?svn=224# in Chrome.
I have all the settings enabled:
transport=udp,ws
encryption=yes
avpf=yes
icesupport=yes

Chrome shows incoming call, when click on allow microphone acces, I still get error in asterisk console: Got SIP response 603 “Failed to get local SDP” back from and call gets rejected.

Using Asterisk 11.5 with srtp enabled.

If you’re using chrome 35 or superior your error must be the DTLS-SRTP well know issue. Stop posting in every thread, use the forum, google and the jira page to solve it. This is a recurrent issue and has been solved with asterisk patchs and sipml5 work around.

@Navaismo, thank you for your reply. I spent more than a week googling in search for the solution, but I didn’t manage to get any page that clearly points way to make webrtc working with asterisk. You were mentioning asterisk patches, but all the patches that are mentioned on forums and some older tutorials are addressing issues from older asterisk versions and older browser versions. I tried both from Chrome 35.0.1916.153 m and Firefox 30 but no success. I (and probably lot of other people with the same issue) would really appreciate if you could post link that has proven working solution. If that would be to bothering to you, if you point me to right direction, I would invest my time and write complete step-by-step tutorial for people in order to get webrtc and asterisk to install from scratch and have it working. I think that open-source community at the moment don’t have one that works with current Asterisk and browser versions. Maybe I’m wrong, and I would be happy if there is a link with coplete, working instructions. Thank you in advance.

I have worked for 4 months before my first call between Chrome and my asterisk, and then 4 months to integrate the webrtc to FreePBX and Elastix.

Already did that: viewtopic.php?f=1&t=90167

Your issue seems to fit in the last Issue added on June 4 of that link.

A huge work was done in the Jira page issues.asterisk.org/jira/browse/ASTERISK-22961 to resolve another ones.

Me and others already spent a lot of time helping the community with webrtc you can check the asterisk IRC log, my blog or my github repo. But people seems to be lazy to use google and find the solution by yourself. I´m not complaining but if you see the the IRC logs ar how many threads about asterisk+webrtc are opened daily with the same issues you will found that exhausting.

Developers from JsSIP doesn´t provide Help about their API with asterisk because repetitive threads, folks on doubango already provided a temporary patch and instruccions to use the media gateway with DTLS support.

Asterisk Developers are already tired of this too --> joshua-colp.com/webrtc-let-m … t-on-that/

So please, before flooding the IRC or the Forum do a deeper search, a week spent is like nothing since most of us are trying to work with this since the past year do the math and calculate our free time spent for the community.

If you want to work like the most of users without go deeper let me tell you something: Go download Elastix 2.4 install my WebRTC addon(WebRTC Agent Console) then use google translate to understand my tutorial here asterisktools.blogspot.com/2013/ … e-con.html

And finally apply this patch forum.elastix.org/viewtopic.php?f=18&t=128877 to the Elastix system and use it until Chrome 37 finally break everything.

Best Regards.

Hi navaismo,

I appreciate your contribution to the community. Most of your entries were helpful for me
while troubleshooting the problems, especially related to WebRTC.
Currently, I am trying to make a call browser-to-softphone via Asterisk. And actually it is done on Ubuntu 14.04 with Asterisk 11.11.0. Now I need to do the same on other machine, which is Elastix 2.4 distro. I would like to know, is it ok upgrading the Asterisk on Elastix by building Asterisk from the source? Or there is another more preferred way? Would you mind if I ask you to see my real problem here viewtopic.php?f=1&t=90890.

You try a 32-bit system to try again.I also encountered this problem before, finally i solved into a 32-bit system.Because the SRTP compile properly under 64