Registration issue

Hi Everybody,

Have a question to the experienced people:

I have a system (domU, Xen):

with:

OS: Ubuntu 10.10 Linux vm04 2.6.35-28-server #50-Ubuntu SMP Fri Mar 18 18:59:25 UTC 2011 x86_64 GNU/Linux
Asterisk: Asterisk 1.6.2.7-1ubuntu1.1 built by buildd @ allspice on a x86_64 running Linux on 2011-01-21 14:59:57 UTC

(it’s domU env. XEN)

I can watch for the strange things with registration,

  1. I don’t like that all extensions:
    Name/username Host Dyn Nat ACL Port Status
    234567/234567 x.x.x.x D N A 62478 UNREACHABLE

which are configured with “nat=yes”, showing us configured without nat

(maybe just output issue?)

  1. Registration issue, all extensions able to register on asterisk, but in about 30 - 60 secs, asterisk lost data abut registration ( can’t qualify? ) and all they are with status UNREACHABLE and stop working.

Can somebody help me with this issue please?

P.S. Exactly the same configuration work under dom0 without any issues.

Thanks for the help!

That’s a qualify issue. Your example in the first part shows that is is showing unreachable even when it has a valid peer address.

David,

I just pst an example when Status was changed. As soon as client is just registered, I see valid peer ip, port and response time (90 - 120 ms in Status field), than in 30 - 60 secs (asterisk trying to qualify again extension) - and all extensions behind nat goig to Unreacheble state, but peers with public IP is still active.

So, I thing there is some issue with VPS or maybe with dom0 network configuration.

Looks liks issue resolved.

I have changed port from 5060 to 5062 and my registration is active for more than 10mins.

Thanks all.