Redirecting outside got mute calls


I have fine working Asterisk 1.4. I may call outside and inside, receive external calls and transfer them to internal users or voicemail. Everything seems OK. Now I wannted to pass every call to one user to his cellular after office hours. Sounds easy:

exten => s,1,Set(SipAcc=${ARG1})
exten => s,2,Set(NumToDial=${ARG2})
exten => s,3,Set(TimeOut=${ARG3})
exten => s,4,Set(Flags=${ARG4})
exten => s,5,Dial(SIP/${NumToDial}@${SipAcc},${TimeOut},${Flags})

exten => s,1,GotoIfTime(15:00-08:00,mon-fri,,?ptr,1)
exten => ptr,1,Macro(DialSipEx,${xofa_ola},${ralph},60,tT)
exten => ptr,n,Hangup()

Asterisk properly calls his handy and seems to establish connection, but nobody can hear anything. Like a mute call. Do you have any idea what do I do wrong? If any detailed configuration needed I will supply.

Thx in advance

Maybe a codec mis-match?

Have you tried the connection with debug output to the log?

Maybe a codec mis-match?
in my sip.conf is:

Anyhow I may call any phone from this system and works fine.

Have you tried the connection with debug output to the log?
No, how to?

I think the first thing you will want to do is just check the log file (maybe in /var/log/asterisk/messages?). Unless you changed your /etc/asterisk/logger.conf file, the messages file is probably already receiving notice, warning and error messages.

If you need more information, then look in logger.conf for the line:

and change it to something like


asterisk -r

host*CLI> logger reload[/code]

This should produce more output to the messages file. (Just remember to remove the change after the testing.)

Good Luck