Redirect channels FROM Meetme causes hangup

Hi everybody.
I’ve upgraded from Asterisk 1.4 to Asterisk and maybe I found a bug. I can’t find this problem discussed anywhere, so I try to find here someone who point me in the right direction.
The problem is using the function redirect from AMI.
This is the scenario.
Two users are connected in a conference (ie with channels SIP/401-000001c and SIP/402-000001f)
If I try to redirect one of this channels out from the conference, no matter on what extension of the dialplan I redirect it, the the redirected channel is hanged up immediatly after “entering” into the new extension.
From the CLI I can see the correct redirection to the new extension, but after that, the channel is always hanged up.
The same if I redirect the other of the two channels.
Redirecting channels not from a meetme conference (ie from a two channels bridge) works well.

Using the same dialplan and the same manager commands in Asterisk 1.4 works perfecty.
Is a mistake of mine in configuring something on the new 1.6 asterisk server?
Is it a bug? Anyone experienced the same? There is a new 1.6 SVN with this bug fixed?

Any help will be appreciated.

Tried with fresh installation of Asterisk 1.4. The problem still remains, so is not a problem dealing with Asterisk 1.6
I will try to focus on using zapata (installed where redirection actually work) instead of dahdi (installed where redirection doesn’t work).
Any other idea?

It’s a bug! Maybe also in version 1.8 (I didn’t tried). Revert to Asterisk 1.4.27 and redirection works.
Does anyone have information on the solution of this bug?