Reciver cant here me


I have a problem. When i calling to someone they cant here me talk but i can here them talk. What can be the problem ?

I hope someone can help me out of this problem.

sip settings info

[quote]Global Settings:

UDP Bindaddress:
TCP SIP Bindaddress: Disabled
TLS SIP Bindaddress: Disabled
Videosupport: No
Textsupport: No
Ignore SDP sess. ver.: No
AutoCreate Peer: No
Match Auth Username: No
Allow unknown access: Yes
Allow subscriptions: Yes
Allow overlap dialing: No
Allow promisc. redir: No
Enable call counters: No
SIP domain support: No
Realm. auth: No
Our auth realm asterisk
Use domains as realms: No
Call to non-local dom.: Yes
URI user is phone no: No
Always auth rejects: Yes
Direct RTP setup: No
User Agent: Asterisk PBX 10.11.0
SDP Session Name: Asterisk PBX 10.11.0
SDP Owner Name: root
Reg. context: (not set)
Regexten on Qualify: No
Trust RPID: No
Send RPID: No
Legacy userfield parse: No
Caller ID: asterisk
From: Domain:
Record SIP history: Off
Call Events: Off
Auth. Failure Events: Off
T.38 support: No
T.38 EC mode: Unknown
T.38 MaxDtgrm: -1
SIP realtime: Disabled
Qualify Freq : 60000 ms
Q.850 Reason header: No

Network QoS Settings:

IP ToS RTP audio: CS0
IP ToS RTP video: CS0
IP ToS RTP text: CS0
802.1p CoS SIP: 4
802.1p CoS RTP audio: 5
802.1p CoS RTP video: 6
802.1p CoS RTP text: 5
Jitterbuffer enabled: No

Network Settings:

SIP address remapping: Disabled, no localnet list
Externaddr: (null)
Externrefresh: 10

Global Signalling Settings:

Codecs: (gsm|ulaw|alaw|h263|testlaw)
Codec Order: ulaw:20
Relax DTMF: No
RFC2833 Compensation: No
Symmetric RTP: No
Compact SIP headers: No
RTP Keepalive: 0 (Disabled)
RTP Timeout: 0 (Disabled)
RTP Hold Timeout: 0 (Disabled)
MWI NOTIFY mime type: application/simple-message-summary
DNS SRV lookup: No
Pedantic SIP support: Yes
Reg. min duration 60 secs
Reg. max duration: 3600 secs
Reg. default duration: 120 secs
Outbound reg. timeout: 20 secs
Outbound reg. attempts: 0
Notify ringing state: Yes
Include CID: No
Notify hold state: No
SIP Transfer mode: open
Max Call Bitrate: 384 kbps
Auto-Framing: No
Outb. proxy:
Session Timers: Accept
Session Refresher: uas
Session Expires: 1800 secs
Session Min-SE: 90 secs
Timer T1: 500
Timer T1 minimum: 100
Timer B: 32000
No premature media: Yes
Max forwards: 70

Default Settings:

Allowed transports: UDP
Outbound transport: UDP
Context: default
Force rport: Yes
DTMF: rfc2833
Qualify: 0
Use ClientCode: No
Progress inband: Never
MOH Interpret: default
MOH Suggest:
Voice Mail Extension: asterisk[/quote]

Please provide the actual sip.conf and a sip debug trace containing the SDP exchange.

You haven’t even provided the device specific SIP configuration, and your printout will contain too many default settings.


Here is my sip.conf

Still no SIP debug trace. Likely that there’s NAT involved and that’s what’s causing the one-way audio.

Hello, Here is all data i get from asterisk.

[quote] == Using SIP RTP CoS mark 5
– Executing [4733284007@from-didww:1] Dial(“SIP/”, “SIP/4733284007,60”) in new stack
== Using SIP RTP CoS mark 5
– Called SIP/4733284007
– SIP/4733284007-0000000f is ringing
== Spawn extension (from-didww, 4733284007, 1) exited non-zero on ‘SIP/’
== Using SIP RTP CoS mark 5
– Executing [4733284007@from-didww:1] Dial(“SIP/”, “SIP/4733284007,60”) in new stack
== Using SIP RTP CoS mark 5
– Called SIP/4733284007
– SIP/4733284007-00000011 is ringing
– SIP/4733284007-00000011 answered SIP/
– Locally bridging SIP/ and SIP/4733284007-00000011
== Spawn extension (from-didww, 4733284007, 1) exited non-zero on ‘SIP/’

try adding this lines to general section in the sip.conf


  • replace with your local network and with your local network mask if u have a local network. externip should be your public IP to your pbx server.

If nat is needed, note that nat=yes is deprecated in the most recent versions. If the above works, I would then try it without nat=, as I’m not convinced that it is needed for simple inbound traversals.