Questions setup FXO card


#1

Hello Everyone,

I setup my asterisk server last night and install my FXO card. When my linux box boots I get error when trying to bring zaptel up. Error is “Loading zaptel framework: modprobe: Can’t locate module zaptel” . Not sure what that error message means. I’m just trying to get my asterisk server up and connected to my broadvoice VOIP service. Please help

thank you,

Desipher


#2

can you give more info about your system.
Linux Version, What kind/brand of FXO Card, etc.


#3

Did you compile and load zaptel?


#4

Im having the same problem as desipher.

I have a Digium Wildcard X100P. I installed asterisk from the iso file i downloaded off sourceforge, it formated my drive and installed asterisk.
I was able to setup asterisk and get my sip phone on my laptop connected to it, however i cannot call out, and when i call my phone number it just keeps ringing, i think that maybe the drivers arent installed for the card. when i get home tonight ill post more info like what kernel i have, to be honest im not very good with linux, this is my first real project using it so any help is greatley appreciated. thanx :smile:

I tried doing a zapconfigtel (forgive me im at work and cant remember the exact command) and it told me i could not do this while asterisk was running i put a -s after the command like it suggested and it looked like it just shutdown and restarted asterisk.

I bought the card off ebay and in the ebay auction it had this info.

[quote]Just insert the card into the Linux Machine and proceed with the following commands,

modprobe zaptel
modprobe wcfxo (Our card works with asterisk wcfxo driver)
ztcfg[/quote]

i ran that, and the machine looked like it excepted the commands, but gave me no response.

thanks in advance.

P.S. I also did the auto updates.


#5

i havent installed zaptel yet, or recompiled my kernel.

ill do that when i get home today and see if that fixed my problem.

heres the link

http://www.voip-info.org/wiki-Asterisk+Zaptel+Installation


#6

Is the recommended kernel to config my FX0 card 2.4.28? because I’m running kernel 2.4.27.

Linux version 2.4.21-27.0.2.EL (centos@centos-athlon) (gcc version 3.2.3 20030502 (Red Hat Linux 3.2.3-42)) #1 Wed Jan 19 02:20:34 GMT 2005


#7

Sorry I little bit newb to asterisk and just trying to get to work with Broadvoice phone service. My setup is old 266 p2 machine with FX0 modem card in it from e-bay. I running asterisk@home with AMP webinterface. I setup trunk for BV with my account info and setup to route and I get nothing. No dial tone and I can’t access by hitting *7 the asterisk box.


#8

im also new to linux, the version of linux used by that asterisk iso, is centos, i believe, which is a clone of redhat, i also have Linux version 2.4.21-27.0.2.EL (centos@centos-athlon) (gcc version 3.2.3 20030502 (Red Hat Linux 3.2.3-42)), we might have to update our kernel from redhats site. before compiling the zaptel drivers.


#9

Try this:
voip-info.org/wiki-Asterisk+ … 4.0+Zaptel


#10

When you get that error it means you need to compile and install the zaptel drivers, how to do this is serioulsy easy,

Taken from a geek gazette howto here http://geekgazette.com/index.php?option=com_content&task=view&id=21&Itemid=31

Re-Compile the Zaptel Driver

[root@asterisk1 root]# cd /
[root@asterisk1 /]# cd /usr/src/zaptel
[root@asterisk1 zaptel]# make clean
[root@asterisk1 zaptel]# make install
[root@asterisk1 zaptel]# shutdown -r now 

you dont need to download anything extra, this should all come on the cd and be installed from the asterisk 0.9 iso.

as for what zmanea said, we are using

“CentOS release 3.4 (final)
Kernel 2.4.21-27.0.4.EL on an I686”

this is after running the yum update.
i havent yet tried what he said. i will probably cause im still having a problem.

Even after installing my digium card. and compiling my zaptel drivers. my card is still not accepting inbound calls, when i try to check my logs by going to

to see if my card was accepted by centOS and installed i get the error.

when i call my phone number, it just rings and rings, also i cannot make outgoing phone calls, so the card is acting the same way, any ideas?

do i need to recompile my kernel after compiling zaptel?


#11

ok so I recompile Zaptel. I will test again tonight when I get home. Is there anyway I can test it remotely see if it will work? I can ssh into that box. So if I’m running asterisk and have Digium Wildcard X100P card and I setup in AMP (gui website config) and I add truck for Broadvoice and setup route for it . It should work right?


#12

I’m trying to achieve the same results on Debian… and I would like to load asterisk on startup automatically.

I followed the rules above without success… I did receive a message stating **** NO RULE TO MAKE TARGET INSTALL

All I did was go to the directory where asterisk is located and typed the following :

/etc/asterisk

make clean
make install
make config

also whent to /etc/modprobe.d/zaptel

and did the same

make clean
make install
make config

I want asterisk to start automatically and modprobe zaptel, modprobe wcfxo to do it’s thing without any user intervention…

Can someone please walk me through this… I seem to be having a problem. I never compiled anything in linux before…

–Tommy