Qos Problem


#1

I’m having a problem with the sound quality of our asterisk server with remote extension. first we have asterisk 1.2 and Covad DSL @ 1.5Mbps upload and download, the remote extension connects to cable modem @ 4.5Mbps . when making calls from the remote extension it cuts off for less than half second (jitter) there is no nat in between. all connects to public IP address. i tried the remote telephone from another location , also soft phones but still having problems. also i used G.729 codec with the same result!
is there any solution or test tools to find out where the problem is coming from?
please help.


#2

Is the remote extension a softphone? If so, that’s probably your problem. Try a hardphone there and see if it fixes it.


#3

Why would softphone be a problem?


#4

they are hard phones (Polycom 500) and Grandstrem 200, they are all having the same problem.


#5

[quote=“parcina”]
Why would softphone be a problem?[/quote]
Well, it seems to be fairly rare, and almost all of the time softphones work ok, but i’ve had similar problems with softphones.

It seems to be something to do with the hardware, although i never managed to put a finger on what it was. But i think it may have been some sort of interrrupt interaction between the onboard soundcard and the onboard ethernet port or something like that. It was on a IBM Thinkpad A20m laptop, but i’ve come across the same problem on a different thinkpad (of a similar age). If it happens on Thinkpads, it could happen with other hardware too - although, admittedly, it’s not very likely.

Agabr: the only tool i can think of that may help a bit is ethereal. You’ll be able to examine the audio packets, which may help get a clearer picture of what’s happening.