Problème d'installation dahdi

Bonjour,
J’ai un problème avec l’installation de dahdi, j’ai téléchargé la dernière version de dahdi je l’ai installé sous debian, mais rien ne s’installe, quand je fais cette commande /etc/init.d/dahdi start, j’ai l’erreur suivante :
Loading DAHDI hardware modules:

Running dahdi_cfg: done.
Missing '/sys/bus/astribanks/drivers/xppdrv/sync

quand j’essaie d’appeler j’ai cette erreur:

[Sep 26 11:56:06] WARNING[21762]: channel.c:5711 ast_request: No channel type registered for ‘dahdi’
[Sep 26 11:56:06] WARNING[21762]: app_dial.c:2345 dial_exec_full: Unable to create channel of type ‘dahdi’ (cause 66 - Channel not implemented)

Merci pour votre aide

Quel est le contenu de

/etc/dahdi/modules

et

/etc/dahdi/system.conf ?

Quel est le résultat de

?

Please use Asterisk Support, next time.

This sounds like you have tried to install a dahdi package compiled against a different kernel from the kernel you actually booted.

[quote=“abw1oim”]Quel est le contenu de

/etc/dahdi/modules

et

/etc/dahdi/system.conf ?

Quel est le résultat de

?[/quote]

le contenu de /etc/dahdi/modules est:

Autogenerated by /usr/sbin/dahdi_genconf (Dahdi::Config::Gen::Modules) on Mon Sep 9 10:16:10 2013

If you edit this file and execute /usr/sbin/dahdi_genconf again,

your manual changes will be LOST.

Le contenu de /etc/dahdi/system.conf est:

Autogenerated by /usr/sbin/dahdi_genconf on Thu Sep 26 12:09:23 2013

If you edit this file and execute /usr/sbin/dahdi_genconf again,

your manual changes will be LOST.

Dahdi Configuration File

This file is parsed by the Dahdi Configurator, dahdi_cfg

Span 1: WGSM/0 “Wanpipe GSM Board 1” (MASTER)

le résultat de dahdi_scan est:
[1]
active=yes
alarms=OK
description=Wanpipe GSM Board 1
name=WGSM/0
manufacturer=Sangoma Technologies
devicetype=W400
location=SLOT=4, BUS=49
basechan=1
totchans=2
irq=0
type=analog
port=1,none
port=2,none
[2]
active=yes
alarms=RED
description=Wanpipe GSM Board 2
name=WGSM/1
manufacturer=Sangoma Technologies
devicetype=W400
location=SLOT=4, BUS=49
basechan=3
totchans=2
irq=0
type=analog
port=3,none
port=4,none
[3]
active=yes
alarms=RED
description=Wanpipe GSM Board 3
name=WGSM/2
manufacturer=Sangoma Technologies
devicetype=W400
location=SLOT=4, BUS=49
basechan=5
totchans=2
irq=0
type=analog
port=5,none
port=6,none
[4]
active=yes
alarms=RED
description=Wanpipe GSM Board 4
name=WGSM/3
manufacturer=Sangoma Technologies
devicetype=W400
location=SLOT=4, BUS=49
basechan=7
totchans=2
irq=0
type=analog
port=7,none
port=8,none

Intéressant … que tout semble bon. Puisque vous avez maintenant encore chercher d’autres choses…
Si je ne me trompe pas , il s’agit d’une carte de Sangoma (W400 GSM).
Y at-il un message d’erreur après la

en /var/log/messages (ou /var/log/syslog)

Et vous avez effectué

(voir http://wiki.sangoma.com/wanpipe-linux-asterisk-dahdi) ?

Et quel est le résultat de

Ce que vous voyez dans Asterisk (début CLI d’un asterisque -rvvvvv ) à

module load chan_dahdi.so?

[quote=“abw1oim”]Intéressant … que tout semble bon. Puisque vous avez maintenant encore chercher d’autres choses…
Si je ne me trompe pas , il s’agit d’une carte de Sangoma (W400 GSM).
Y at-il un message d’erreur après la

en /var/log/messages (ou /var/log/syslog)

Et vous avez effectué

(voir http://wiki.sangoma.com/wanpipe-linux-asterisk-dahdi) ?

Et quel est le résultat de

Ce que vous voyez dans Asterisk (début CLI d’un asterisque -rvvvvv ) à

Oui c’est une carte sangoma w400 :smile:
Quand je fais wanrouter start il n’y a aucun message d’erreur

[quote]Starting WAN Router…
Loading WAN drivers: wanpipe done.
Starting up device: wanpipe1
Starting up device: wanpipe2
Starting up device: wanpipe3
Starting up device: wanpipe4
Configuring interfaces: w1g1
done.
Configuring interfaces: w2g1
done.
Configuring interfaces: w3g1
done.
Configuring interfaces: w4g1
done.
Waiting for Dahdi /dev/dahdi …
DAHDI Tools Version - 2.7.0.1

DAHDI Version: 2.7.0.1
Echo Canceller(s):
Configuration

8 channels to configure.

Setting echocan for channel 1 to none
Setting echocan for channel 2 to none
Setting echocan for channel 3 to none
Setting echocan for channel 4 to none
Setting echocan for channel 5 to none
Setting echocan for channel 6 to none
Setting echocan for channel 7 to none
Setting echocan for channel 8 to none[/quote]

wancfg_dahdi
Voila le fichier system.conf

Ok, problème trouvé:

Pour résoudre l’erreur, suivez les instructions pour continuer (note en particulier: Asterisk LibWAT Patching):

http://wiki.sangoma.com/wanpipe-linux-asterisk-gsm

[quote=“abw1oim”]Ok, problème trouvé:

Pour résoudre l’erreur, suivez les instructions pour continuer (note en particulier: Asterisk LibWAT Patching):

http://wiki.sangoma.com/wanpipe-linux-asterisk-gsm[/quote]

j’ai fais toutes les instructions, puis j’ai fais module load chan_dahdi.so voilà ce que ça donne

[quote]Unable to load module chan_dahdi
Command ‘module load chan_dahdi’ failed.
== Registered application ‘DAHDISendKeypadFacility’
== Registered application ‘DAHDISendCallreroutingFacility’
== Parsing ‘/etc/asterisk/chan_dahdi.conf’: == Found
== Parsing ‘/etc/asterisk/users.conf’: == Found
[Sep 27 09:50:17] ERROR[24583]: chan_dahdi.c:17410 process_dahdi: Unknown signalling method ‘gsm’ at line 37.
[Sep 27 09:50:17] WARNING[24583]: chan_dahdi.c:12055 pri_resolve_span: Unable to use span 0, since the D-channel cannot be located (unexpected span size of 2 channels)
[Sep 27 09:50:17] WARNING[24583]: chan_dahdi.c:12565 mkintf: Channel 1: Unable to find locate channel/trunk group!
[Sep 27 09:50:17] ERROR[24583]: chan_dahdi.c:16896 build_channels: Unable to register channel ‘1’
[/quote]

Hmm, l’erreur a changé.
Maintenant, il ya des signes que le fichier /etc/asterisk/chan_dahid.conf pas vrai. ( L’erreur est allé à libwat.so.1.0.24 )

J’ai trouvé un problème similaire (freepbx.org/forum/freepbx/in … stallation), mais aucune solution.

Demandez fois avec Sangoma - dans leur wiki rien trouvé à en effet !

[quote=“abw1oim”]Hmm, l’erreur a changé.
Maintenant, il ya des signes que le fichier /etc/asterisk/chan_dahid.conf pas vrai. ( L’erreur est allé à libwat.so.1.0.24 )

J’ai trouvé un problème similaire (freepbx.org/forum/freepbx/in … stallation), mais aucune solution.

Demandez fois avec Sangoma - dans leur wiki rien trouvé à en effet ![/quote]
Je pense je sais c’est quoi le problème,
en fait j’ai téléchargé la version asterisk-1.8.23.1 disponible dans le site d’asterisk alors pour le patch c’est asterisk-1.8.9.0.patch
donc j’ai besoin de télécharger la version d’asterisk 1.8.9.0 mais le problème dans le site asterisk je ne trouve que la derniére version.

Je ne pense pas que cela fait une différence, mais la version Asterisk 1.8.9 est disponible ici:

downloads.asterisk.org/pub/telep … 9.0.tar.gz