Problem with RTP through Asterisk


#1

Hi,
I am new with *. I have system with one digium TE210 ( dual span ) card. HW componets looks to work fine, I can make call from PSTN line to the PRI line and enter the standard demo aplication.
There is also no problem with SIP phones and soft phones if they are registerd on *, and if “native bridge” from * is established.
All problems become when * needs to be between two parties. If it is a SIP call comming from external proxy ( SER where my * is registerd ) to any of my local SIP phones, or PSTN call trying to rech some of my local SIP phones. Signaling packets are exchanged, so the call is initiated and established, but later only RTP packets to my * are traced, and no RTP packet out of * to any external device. Also there is no voice on the phone line even there is no need to make any CODEC conversion, ( I use the g711ulaw which is also used for PSTN calls )
Any idea where is the problem.
I can post my conf files if somebody wants to help me !
regards


#2

Try adding a “canreinvite=no” to your peers and users. With this option Asterisk should always be in the media path.

Stoyan


#3

Hi,
Thanks for the advice, but it doesn’t solve the problem, because I have tried it allredy before.
My system was running Asterisk 1.2.2 and after patching it with the latest available version 1.2.6, on the same configuration everything works fine.
I am not sure where was the problem, with some module in the previous instalation, but there was no error report on the console in debug mode, and that why it it more strange.
Regards to everyone


#4

There was an old bug, causing asterisk not to pass audio after some date… I think 1.2.3 fixed it.


#5

Are there problems from one SIP phone to another within your LAN? It sounds like you have a NAT problem except you say even incoming PSTN calls don’t get to your SIP phones, which doesn’t involve NAT. It’s not a firewall issues is it?

To take the NAT problem route, make sure you’ve configured sip.conf accordingly by defining the externalip and localnet items and nat=yes.