Problem with Polycom RMX 1500

I had Asterisk 1.4 as a SIP server and Polycom RMX Server. They are both in local network Everything worked fine, but I decided to update to the recent version of AsteriskNow 32-bit. Now after some time (few hours) my RMX disconnects from Asterisk and I get an error in RMX console “Failed to connect tt SIP registrar”. So, I have to reboot my RMX and it connects to SIP server again but after few hours it disconnects again and did not ever reconnects.
I revert back to asterisk 1.4 and the problem is gone.
I looked through fail2ban and RMX logs and Iptables -L -n in time of disconnection but did not found anything useful.
If I start my previous asterisk 1.4 server, Polycom RMX with faulty connection connects again without rebooting RMX with no problem.
I tried to use pedantic=no/yes without result.
I tried to make Refresh Registration parameter in RMX to 300 seconds, so time till disconnection took longer (about 8 hours). Usually it takes 1-2 hours till disconnection.
What can cause such problem?

my Iptables rules:
-N fail2ban-BadBots
-N fail2ban-FTP
-N fail2ban-SIP
-N fail2ban-SSH
-N fail2ban-apache-auth
-N fail2ban-recidive
-A INPUT -p tcp -m multiport --dports 21 -j fail2ban-FTP
-A INPUT -p tcp -m multiport --dports 80 -j fail2ban-apache-auth
-A INPUT -j fail2ban-SIP
-A INPUT -j fail2ban-SIP
-A INPUT -p tcp -m multiport --dports 22 -j fail2ban-SSH
-A INPUT -j fail2ban-recidive
-A fail2ban-BadBots -j RETURN
-A fail2ban-FTP -j RETURN
-A fail2ban-SIP -j RETURN
-A fail2ban-SIP -j RETURN
-A fail2ban-SSH -j RETURN
-A fail2ban-apache-auth -j RETURN
-A fail2ban-recidive -j RETURN