Problem with mixmonitor

Hi,
I use asterisk 13.9.1 everything is ok and when I decided to use mixmonitor I have an issue.
When I start a call there is no sound. No one hear the other and when I play the record file the conversation is recorded !
Thank you.

Edit :

by enabling debug mode I see this error message :
audiohook.c:329 audiohook_read_frame_both: Failed to get 160 samples from write factory 0x7f829403ed38

Post your dialplan plus make a test call and post what the cli shows.

This issue could be related to your system check this https://issues.asterisk.org/jira/browse/ASTERISK-18937

[work]
exten => _1XXX,1,Set(FILENAME=${UNIQUEID})
exten => _1XXX,n,Set(monopt=nice -n 19 lame -b 16 --silent /home/desktop/asterisk/${FILENAME}.wav /home/desktop/asterisk/${FILENAME}.mp3 && rm -f /home/desktop/asterisk/${FILENAME}.wav)
exten => _1XXX,n,MixMonitor(/home/desktop/asterisk/${FILENAME}.wav,b,${monopt})
exten => _1XXX,n,Dial(SIP/${EXTEN},20)
exten => _1XXX,n,Hangup()

Cli :

– Executing [1000@work:1] Set(“SIP/1001-00000008”, “FILENAME=1468840424.9”) in new stack
– Executing [1000@work:2] Set(“SIP/1001-00000008”, “monopt=nice -n 19 lame -b 16 --silent /home/desktop/asterisk/1468840424.9.wav /home/desktop/asterisk/1468840424.9.mp3 && rm -f /home/desktop/asterisk/1468840424.9.wav”) in new stack
– Executing [1000@work:3] MixMonitor(“SIP/1001-00000008”, “/home/desktop/asterisk/1468840424.9.wav,b,nice -n 19 lame -b 16 --silent /home/desktop/asterisk/1468840424.9.wav /home/desktop/asterisk/1468840424.9.mp3 && rm -f /home/desktop/asterisk/1468840424.9.wav”) in new stack
– Executing [1000@work:4] Dial(“SIP/1001-00000008”, “SIP/1000,20”) in new stack
== Begin MixMonitor Recording SIP/1001-00000008
[Jul 18 13:13:44] WARNING[4213][C-00000009]: sip/config_parser.c:815 sip_parse_nat_option: nat=yes is deprecated, use nat=force_rport,comedia instead
== Using SIP RTP CoS mark 5
– Called SIP/1000
– SIP/1000-00000009 answered SIP/1001-00000008
– Channel SIP/1000-00000009 joined ‘simple_bridge’ basic-bridge <0550b5da-1118-4a60-ad3a-21a06f13a1de>
– Channel SIP/1001-00000008 joined ‘simple_bridge’ basic-bridge <0550b5da-1118-4a60-ad3a-21a06f13a1de>
> 0xc26f70 – Probation passed - setting RTP source address to 41.137.40.151:10747
> 0xc26f70 – Probation passed - setting RTP source address to 41.137.40.151:10747
> 0x7f688c022300 – Probation passed - setting RTP source address to 41.137.40.151:10749
> 0x7f688c022300 – Probation passed - setting RTP source address to 41.137.40.151:10749
– Channel SIP/1001-00000008 left ‘simple_bridge’ basic-bridge <0550b5da-1118-4a60-ad3a-21a06f13a1de>
– Channel SIP/1000-00000009 left ‘simple_bridge’ basic-bridge <0550b5da-1118-4a60-ad3a-21a06f13a1de>
== Spawn extension (work, 1000, 4) exited non-zero on ‘SIP/1001-00000008’
== MixMonitor close filestream (mixed)
== Executing [nice -n 19 lame -b 16 --silent /home/desktop/asterisk/1468840424.9.wav /home/desktop/asterisk/1468840424.9.mp3 && rm -f /home/desktop/asterisk/1468840424.9.wav]
== End MixMonitor Recording SIP/1001-00000008

Note :
I have no sound card installed because I use dedicated server I don’t know if Mixmonitor need the card or not