Problem with displaying incorrect incoming caller number


#1

I have a fully working Asterisk@Home 2.1 and only problem is that in caller ID , my own number (6107171091) is disaplyed for every incoming phone number while the caller ID is correctly displayed. I have posted this problem on a couple of forums and did not get much help. I am also posting my debug for help. Thanks

– Executing Goto(“SIP/6107171091-f947”, “from-pstn-timecheck|s|1”) in new stack
– Goto (from-pstn-timecheck,s,1)
– Executing GotoIf(“SIP/6107171091-f947”, “1?from-pstn-reghours|s|1:”) in new stack
– Goto (from-pstn-reghours,s,1)
– Executing GotoIf(“SIP/6107171091-f947”, “0?from-pstn-reghours-nofax|s|1:2”) in new stack
– Goto (from-pstn-reghours,s,2)
– Executing Answer(“SIP/6107171091-f947”, “”) in new stack
– Executing Wait(“SIP/6107171091-f947”, “1”) in new stack
– Executing SetVar(“SIP/6107171091-f947”, “intype=EXT-200”) in new stack
– Executing Cut(“SIP/6107171091-f947”, “intype=intype|-|1”) in new stack
– Executing GotoIf(“SIP/6107171091-f947”, “1?7:9”) in new stack
– Goto (from-pstn-reghours,s,7)
– Executing Wait(“SIP/6107171091-f947”, “3”) in new stack
– Executing Goto(“SIP/6107171091-f947”, “ext-local|200|1”) in new stack
– Goto (ext-local,200,1)
– Executing Macro(“SIP/6107171091-f947”, “exten-vm|200|200”) in new stack
– Executing Macro(“SIP/6107171091-f947”, “user-callerid”) in new stack
– Executing DBget(“SIP/6107171091-f947”, “AMPUSER=DEVICE/6107171091/user”) in new stack
– DBget: varname=AMPUSER, family=DEVICE, key=6107171091/user
– DBget: Value not found in database.
– Executing DBget(“SIP/6107171091-f947”, “AMPUSERCIDNAME=AMPUSER//cidname”) in new stack
– DBget: varname=AMPUSERCIDNAME, family=AMPUSER, key=/cidname
– DBget: Value not found in database.
– Executing GotoIf(“SIP/6107171091-f947”, “1?5”) in new stack
– Goto (macro-user-callerid,s,5)
– Executing NoOp(“SIP/6107171091-f947”, “Using CallerID “Phphsbzn31 PA” <6107171091>”) in new stack
– Executing SetVar(“SIP/6107171091-f947”, “FROMCONTEXT=exten-vm”) in new stack
– Executing Macro(“SIP/6107171091-f947”, “record-enable|200|IN”) in new stack
– Executing GotoIf(“SIP/6107171091-f947”, “0 > 0?2:4”) in new stack
– Goto (macro-record-enable,s,4)
– Executing AGI(“SIP/6107171091-f947”, “recordingcheck|20051217-083600|1134826555.6”) in new stack
– Launched AGI Script /var/lib/asterisk/agi-bin/recordingcheck
recordingcheck|20051217-083600|1134826555.6: Inbound recording not enabled
– AGI Script recordingcheck completed, returning 0
– Executing NoOp(“SIP/6107171091-f947”, “No recording needed”) in new stack
– Executing Macro(“SIP/6107171091-f947”, “dial|15|tr|200”) in new stack
– Executing GotoIf(“SIP/6107171091-f947”, “0?4:2”) in new stack
– Goto (macro-dial,s,2)
– Executing GotoIf(“SIP/6107171091-f947”, “0?5:4”) in new stack
– Goto (macro-dial,s,4)
– Executing AGI(“SIP/6107171091-f947”, “dialparties.agi”) in new stack
– Launched AGI Script /var/lib/asterisk/agi-bin/dialparties.agi
– dialparties.agi: priority = 4
– dialparties.agi: callingani2 = 0
– dialparties.agi: accountcode =
– dialparties.agi: channel = SIP/6107171091-f947
– dialparties.agi: callerid = 6107171091
– dialparties.agi: context = macro-dial
– dialparties.agi: callington = 0
– dialparties.agi: dnid = 6107171091
– dialparties.agi: request = dialparties.agi
– dialparties.agi: calleridname = Phphsbzn31 PA
– dialparties.agi: extension = s
– dialparties.agi: language = en
– dialparties.agi: uniqueid = 1134826555.6
– dialparties.agi: callingpres = 0
– dialparties.agi: type = SIP
– dialparties.agi: rdnis = unknown
– dialparties.agi: callingtns = 0
– dialparties.agi: enhanced = 0.0
dialparties.agi: Caller ID name and number are '6107171091’
dialparties.agi: Methodology of ring is ‘none’
– dialparties.agi: Added extension 200 to extension map
– dialparties.agi: Extension 200 cf is disabled
– dialparties.agi: Extension 200 do not disturb is disabled
> dialparties.agi: extnum: 200
> dialparties.agi: exthascw: 0
> dialparties.agi: exthascfb: 0
> dialparties.agi: extcfb:
– dialparties.agi: Checking CW and CFB status for extension 200
== Parsing ‘/etc/asterisk/manager.conf’: Found
== Parsing ‘/etc/asterisk/manager_custom.conf’: Found
== Manager ‘admin’ logged on from 127.0.0.1
– dialparties.agi: Correct AMPMGRUSER and AMPMGRPASS
== Manager ‘admin’ logged off from 127.0.0.1
> dialparties.agi: extstate: 0
dialparties.agi: Extension 200 is available…skipping checks
– dialparties.agi: DbSet CALLTRACE/200 to 6107171091
– AGI Script dialparties.agi completed, returning 0
– Executing Dial(“SIP/6107171091-f947”, “SIP/200|15|tr”) in new stack
– Called 200
– SIP/200-9cac is ringing


#2

Normally I’d ask you to post your dial plan, since it’s too hard on the eyes to extract the logic by looking through the console output. But since this is *@H, I’m not so sure (I’m not sure, but I think most people here speak naked asterisk, not *@H) that’s the best way to go. You may just have some *@H switch set wrong or something like that. As such, you might be better of going to one of the dedicated *@H forums. Just a thought.