Problem with asterisk addons

I’m upgrading my asterisk server at job to a x86_64. Everything is ok until I tried to install asterisk-addons. I can’t install any mysql related addons (realtime ,addon-sql)
Output of ./configure :

checking build system type... x86_64-unknown-linux-gnu
checking host system type... x86_64-unknown-linux-gnu
checking target system type... x86_64-unknown-linux-gnu
checking for uname... /bin/uname
checking for gcc... gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ISO C89... none needed
checking for g++... g++
checking whether we are using the GNU C++ compiler... yes
checking whether g++ accepts -g... yes
checking for a BSD-compatible install... /usr/bin/install -c
checking whether ln -s works... yes
checking for gawk... gawk
checking for GNU make... make
checking for awk... /bin/awk
checking for grep... /bin/grep
checking for basename... /bin/basename
checking for dirname... /usr/bin/dirname
checking for sh... /bin/sh
checking for ln... /bin/ln
checking how to run the C preprocessor... gcc -E
checking for grep that handles long lines and -e... (cached) /bin/grep
checking for egrep... /bin/grep -E
checking for ANSI C header files... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking for initscr in -lcurses... yes
checking curses.h usability... yes
checking curses.h presence... yes
checking for curses.h... yes
checking for initscr in -lncurses... yes
checking for curses.h... (cached) yes
checking for mysql_config... /usr/bin/mysql_config
checking for mysql_init in -lmysqlclient... no
checking for asterisk.h... yes
configure: creating ./config.status
config.status: creating build_tools/menuselect-deps
config.status: creating makeopts

            .$7$7..          .7$$7:.
          .$$:.                 ,$7.7
        .$7.     7$$$$           .$$77
     ..$$.       $$$$$            .$$$7
    ..7$   .?.   $$$$$   .?.       7$$$.
   $.$.   .$$$7. $$$$7 .7$$$.      .$$$.
 .777.   .$$$$$$77$$$77$$$$$7.      $$$,
 $$$~      .7$$$$$$$$$$$$$7.       .$$$.
.$$7          .7$$$$$$$7:          ?$$$.
$$$          ?7$$$$$$$$$$I        .$$$7
$$$       .7$$$$$$$$$$$$$$$$      :$$$.
$$$       $$$$$$7$$$$$$$$$$$$    .$$$.
$$$        $$$   7$$$7  .$$$    .$$$.
$$$$             $$$$7         .$$$.
7$$$7            7$$$$        7$$$
 $$$$$                        $$$
  $$$$7.                       $$  (TM)
   $$$$$$$.           .7$$$$$$  $$

configure: Package configured for:
configure: OS type  : Linux
configure: Host CPU : x86_64

The problem seem to be there :

checking for mysql_init in -lmysqlclient... no

But i do have mysql-libs install :

[root@localhost asterisk-addons-1.4.6]# ldconfig -v | grep mysql /usr/lib/mysql: -> -> /usr/lib64/mysql: -> ->
And the mysql client is also installed.
Any help would be very nice!

This appears to be a bug in the build system for Asterisk-Addons. Please report it at the Digium bug tracker at and a developer will get back to you as quickly as possible.

Jared Smith
Community Relations Manager
Digium, Inc.

Sorry to revive an old thread but I just experienced the same problem.

It’s not the MySQL lib at all - the error is misleading - ensure you have the correct libz versions installed (if necessary move the ones in /usr/lib64 into /usr/lib as it appears the configure script looks in the wrong place for them)

Also ensure openssl-devel is installed - as this stage will fail if it can’t find libssl.

I did this and it worked fine :smile: