Problem installing Asterisk

I am new to Asterisk as well as EC2. I am trying to install Asterisk
1.4.21 version in my Amazon EC2 terminal for learning purpose.
i have downloaded tarball packages:
Asterisk 1.4.21
Libpri 1.4.4
Zaptel 1.4.11

I extracted the tar balls successfully. Now i need to first install
the Zaptel.
make clean commands are running pretty well. But when i am trying to
make install
it says: “You do not appear to have the sources for the kernel installed.”

Then i tried to fix this with installing kernel-sources available
linux-source-2.6.22 but not working then i tried installing kernel-
headers available

  1. linux-headers-2.6.22-14-xen
  2. linux-headers-2.6.22-15-server
    but having no clue. The result is the same as before. Please help me
    fix this problem.
    Thanks in advance.

Auro :frowning:

Maybe you need the dev. package ?

i have resolved the issue but thanks for the reply.

What was the issue ? It will help others on these forums.

to resolve the issue and get the exact version of kernel source you should take a look here. … amazon-ec2


Thanks for sharing.