Ported Number disconnects at 39 seconds

Hi everyone,

We have an interesting problem here and I would greatly appreciate any input or suggestions.

We are using a Neotel SIP connection which uses Fibre as the last mile connection.
Neotel gave us 99 numbers which are all working fine.
We had 3 numbers ported when we moved away from PSTN which were forwarded to our Neotel numbers.
If a Vodacom (cellular provider) calls any of our Neotel numbers, everything works fine.
If a Vodacom subscriber calls one of the ported numbers, the call is disconnected after 39 seconds every time.
This problems doesn’t affect any of the other cellular provider subscribers or any other callers calling from landlines, just Vodacom subscribers.

I assumed it was a problem with Vodacom/Neotel’s porting and they say it is a fault with the Asterisk Configuration.
One of Neotel’s technicians came out and brought with him a testing tool (essentially a mobile PABX) which he connected to our SIP account and sure enough, the calls all worked fine, even Vodacom calls. This means the fault must be somewhere in the Asterisk setup or trunk config.

Neotel’s tech support sent me the following:

"After a deep investigation with Vodacom and switch vendor, It seems that the Asterisk PBX from your side is triggering our SoftX to send the “CON” message due to the type “Auto Answering” that might be configured on your PBX. This causes Vodacom to release the calls. I am still doing more analysis with switch vendor. "

Please could somebody tell me what this means or if there is something I can do to fix it?

Thanks very much!

According to the Neotel tech, asterisk box is sending a disconnect request to Vodacom.
Use tcpdump or wireshark to capture the SIP packets. This would contain all the relevant codes which you could research or post.

Otherwise create a rule allowing a specific Vodacom number (that you can use to test) and route it directly to a phone extension. Put this rule at the top to be read first. This will tell you if it is something in your dial plan lower down.

I usually put comments after every line being executed so you know where error happens in dial plan.
Make easier to debug

Hope helps


Thanks Rudi, will give it a try tomorrow!

Hooray! The problem has been solved:

Within the Incoming Route settings, there is an option to “Signal RINGING”.
Enabling this solved all our issues.

Thanks to Rudi for pointing me in the right direction!