Please help installing Speex support for Asterisk 1.4

Hi All,

I have been trying all day to get Speex working in Asterisk 1.4.22 on CentOS 5.2 without success. I googled and got bit of information from the Trixbox site and here which got me up to this point. I am overlooking something but I don’t know what.

I tried yum -y install speex speex-devel without success.

Then I downloaded source as follows:

cd /usr/src
wget … rc1.tar.gz
tar -zxvf speex-1.2rc1.tar.gz
mv speex-1.2rc1 speex

Then I compiled it:
cd speex
make install

Then compile Asterisk and build the asterisk speex module.
cd /usr/src/asterisk
./configure --with-speex=/usr/lib/
make and make install

After these steps I am able to see the required in /usr/lib/asterisk/modules but the module is not loading.

Asterisk Ready.
*CLI> module show like codec_
Module Description Use Count ITU G.726-32kbps G726 Transcoder 0 mu-Law Coder/Decoder 0 GSM Coder/Decoder 0 LPC10 2.4kbps Coder/Decoder 0 A-law and Mulaw direct Coder/Decoder 0 Adaptive Differential PCM Coder/Decoder 0 A-law Coder/Decoder 0
7 modules loaded

Isn’t the module meant to load automatically? How can I get speex to load?



Do you have autoload=yes in modules.conf?

Hi Wimnat,

This are the contents of my modules.conf file:

********** begin **************

; Asterisk configuration file
; Module Loader configuration file

; Any modules that need to be loaded before the Asterisk core has been
; initialized (just after the logger has been initialized) can be loaded
; using ‘preload’. This will frequently be needed if you wish to map all
; module configuration files into Realtime storage, since the Realtime
; driver will need to be loaded before the modules using those configuration
; files are initialized.
; An example of loading ODBC support would be:
;preload =>
;preload =>
; Uncomment the following if you wish to use the Speech Recognition API
;preload =>
; If you want, load the GTK console right away.
noload =>
;load =>
load =>
; Load either OSS or ALSA, not both
; By default, load OSS only (automatically) and do not load ALSA
noload =>
;noload =>

********** end **********

Since then I have installed ilbc and that works fine but speex seems to be a problem still.



I just tried installing Asterisk 1.4.22 with Speex support on a different machine and got the same problem!

Can somebody help us out here please?