PJSIP Realtime - Contact URI length

I’m working on integrating Asterisk PJSIP with OpenSIPS 3.0 for voicemail etc. Contact URI’s are storing in my DB OK but I have an issue with contact URI’s with extra parameters.

I’ve got a REPLACE on the DB to change the ; to ^3B which seems to be working as expected.
I see from here:

That the limit should be 512 (characters?) but I am still getting this in my logs:

res_pjsip/location.c: Contact uri or hostname length exceeds pjproject limit or is not a sip(s) uri: rinstance=40e6410c1db924e7
config_options.c: Error parsing contact=rinstance=40e6410c1db924e7 at line 0 of

I was running 16.4.1 so I upgraded to 16.5.0 and I’m using --with-pjproject-bundled but the issue remains.
Am I missing something or is this a real issue?

Many thanks
Mark.

What is the exact value in the database?

sip:5001@XXX.XXX.XXX.XXX:50940^3Brinstance=40e6410c1db924e7

It’s acting as if it is still “;” there… not sure why. I haven’t seen anyone else experience it.

Just re-examining the documentation, it says that the IP address separator should be a colon (:).
Is that correct?

https://wiki.asterisk.org/wiki/display/AST/Setting+up+PJSIP+Realtime#SettingupPJSIPRealtime-ReservedCharacters

I don’t believe that’s correct, I think it was a mistake when editing.

Thanks for the clarification.

I discovered that I had a problem with the column name in the DB which I have corrected but the issue remains.

2019-08-07 15:51:45] ERROR[13657]: res_pjsip/location.c:612 permanent_uri_handler: Contact uri or hostname length exceeds pjproject limit or is not a sip(s) uri: rinstance=40e6410c1db924e7
[2019-08-07 15:51:45] ERROR[13657]: config_options.c:798 aco_process_var: Error parsing contact=rinstance=40e6410c1db924e7 at line 0 of

Could there actually be an issue with the limit in pjproject?
I’m also digging to see if I can see the result returned from the DB.

Looking at pjsip show contacts, the semi-colon is shown in the output. Is that expected or should I expect to see the ^3B ?

It gets translated back into a semi-colon on reading. There may be a bug in either the realtime, config option code, or the data layer… it’s probably best to file an issue[1] with specific reproductions instructions.

[1] https://issues.asterisk.org/jira

Thanks again for the clarification. I’ll go back over my configs etc.