PJSIP One Way Audio behind SBC

I may having something setup wrong but I cannot put my finger on it. I have an Asterisk system (13.22.0 ) running behind an SBC so remote users can register their phones through the SBC to the phone system.

Users running PJSIP with their phones connected to the PBX directly are ok with audio.

Users running PJSIP through the SBC are having one way audio issues on outbound calls. Inbound calls are ok.

For example, extension 500 dials *98. No audio. But if extension 501 dials 500, no audio issues. Let me know what other info I need to provide to help further look into this issue.

What is the configuration? What does “rtp set debug on” show for where media is coming from and going to? Is it what you expect? Do you have direct media enabled?

Hello, the configuration is as follows.

Remote user is registered to abc1.domain.com. This points to the SBC and in the SBC, there’s a rule to push registration traffic on this traffic to the PBX on port 5061 (pjsip is setup to use 5061 on the PBX).

Phone -> abc1.domain.com -> PBX

On the PBX, I have 0.0.0.0 UDP-all activated with port to listen on = yes, external ip address set to the PBX external IP (nat environment).

With SIP debug on, I see traffic going and coming from the public IP of the SBC. This also happens with chan sip and there are no issues with chan sip. For the extension with the audio issues, I checked and direct media is set to true.

Well once I got home and threw a test extension on Zoiper, I have no issues. Ended up registering my extension via TCP and I have full audio.

Edit: Did UDP on my Zoiper as well and no issues.

Well running further tests finding something interesting.

If I register my PJSIP endpoint and contact uri in the sbc is a private IP, no audio. If the contact uri is a public IP, audio is ok.

Try the rtp_symmetric option on your endpoint, If the phone sends audio to asterisk the Asterisk will learn the address to send the RTP back to.

After some changes the issue was related to the SBC and some symmetric RTP settings. We are all set! Thanks for all the help everyone!