PJSIP no audio on calls

Everything worked perfectly on chansip. I moved to PJSIP and I can’t hear audio on any of my calls. NAT was nat=force_rport,comedia for extensions 200 and 300 and nat=no for 100. It worked well and I used the python script to convert sip.conf to pjsip.conf.

If I enable direct media, I’m able to hear one-way.
PJSIP config:


RTP debug shows no log, nothing.

Your NAT settings looks OK

rtp_symmetric = yes
force_rport = yes
rewrite_contact = yes

Try to uncomment the ;ice_support = yes

I commented it because webrtc=yes makes it yes anyway.

I tried uncommenting it, no luck.
No audio but calls are placed without any errors.

I moved to PJSIP because my WebRTC peer wouldn’t qualify and always be unreachable in SIP, but in PJSIP, it is reachable although no audio :broken_heart:

UPDATE: I turned off direct_media(of 200) and and now I can hear one side audio on WebRTC(100)-Softphone(200). Enabling direct_media of 200 and 300 also gives one side audio on 200-300 connection.

I commented the local_net parameter and it’s working perfectly :grin:
Thank you!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.