Pjsip escape # invite

About RFC 2396 the PJSIP don’t send “#” character , but I need force send this in Invite, How can I to do it ?

The PJSIP replace “#” to “%23”

Escaping the # is required to avoid a protocol violation:

user             =  1*( unreserved / escaped / user-unreserved )
user-unreserved  =  "&" / "=" / "+" / "$" / "," / ";" / "?" / "/"
unreserved  =  alphanum / mark
mark        =  "-" / "_" / "." / "!" / "~" / "*" / "'"
               / "(" / ")"
escaped     =  "%" HEXDIG HEXDIG

Yes I know about that, but some carrier request tech prefix in call and we need put # in invite.
For example I need call to +1 306 9999 9999

So I need send 12345#130699999999

12345# is Tech Prefix
130699999999 is Number

PJSIP has no ability to disable that, for the reason that @david551 stated.

Ok, Thank you for answer.