PJSIP and Cisco 79XX phones not registering

Does pjsip support Cisco 79XX series phones. I have had no luck in getting these devices to register with pjsip. Has anyone out there been able to get these phones working with pjsip?

I’m having a problem with a 7960 as well. Keep getting 401 Unauthorized. Tried switching to chan_sip as well. Still no good. Has anyone been able to get this to work lately?

Hi, I have the same problem did you find a solution.

I have Cisco 7940 and Asterisk 13 and the Cisco 7940’s won’t register.


Generally you need to provide debugging information, but, in particular, I would note that failing to get beyond 401 generally indicates a misconfiguration of the authorisation data in the phones.

Also, it is not possible to say that you have the same problem on the basis of the information provided here; there isn’t enough information to work out what the problem is!

This is caused by res_pjsip defaulting to “yes” for force_rport. This option is compatible with pretty much everything but some of the Cisco SIP stacks. It causes SIP responses to go back to the source IP address and port, which is useful for NAT. In the case of Cisco however they send their messages from a randomized source port which drops traffic sent to it. The fix is to set “force_rport=no” for any endpoints which are Cisco phones.