Password root of asteriskNOW?


I am use asteriskNOW

What is the password root?

isn’t it the one you specified during installation ???

The specified during installation is the admin
But not the root.

Thank you

in that case, can you access the box as admin and su to root ?

I do not understand

Yes when the instalation is the admin, but not the root
But I can not, the install the new program. Estando en Internet
For example, netconfig, ifconfig, yum and other commands not found…

i’ve not yet looked at AsteriskNOW (sorry Digium, it doesn’t look right/scan/feel !), but i have to ask … have you read the documentation on the CD front-to-back, top-to-bottom etc etc ?

next, maybe you should get onto the freenode irc network and join #asterisk-now … perhaps they can help ?

i hope you’re not expecting the distro to be more than a bare-bones Asterisk install. the chances are that some of the packages you’re expecting aren’t there.

reboot to the cd
use “linux rescue” when prompted for boot options
chroot /mnt/sysimage
reboot and have access to the system.

good Morning

I avec exactly the same problem!

Login root
Access denied! :frowning:

And i don’t access to asterisk manager (GUI)
no account
no password.

So, what’s the passwords and accounts for asterisknow?
Otherwise whe don’t trying it.!!! :cry:

I trying to make the rescue procedure: niet!!!
with me, the procedure re-install asterisknow.
I use it on VMWare.

Just a thought, but have either of you tried logging in as “admin” with the password that you specified? And then once you are in, have you tried testing to see if “admin” is a sudoer? You can test by logging in as admin and then typing “sudo su”. When it prompts for the password, try using the “admin” password. If that does not work, then you would probably be better served in a forum dedicated to AsteriskNOW as baconbuttie has suggested.

Yes, i trying admin, root, wwwadmin, maint, always access denied. :cry:

No, i can’t do.

Yes, i already to try this forum and only one answer, but no good solution for the moment!
They are surprised that one cannot this connecting root and manage GUI. :laughing:

ha… asterisknow, isn’t for now ! :unamused:

Yes you can use sudo su to gain “root” access
You will be able to edit the config files and you can connect to a Service provider…big deal…that is whta we have been doing…
the GUI is not “working”…

heee… yes, but for using sudo, i must be already login and i don’t have any account!!!
so what account i must use?

do you think we could get the devs of the GUI or the build to come here and answer some of these questions ?

at the moment my Asterisk dev machine is a Mac G3 and the distro sure isn’t going to work on that. might be time to try it in a VM (as the screenshots appear to have done)

Simply i try to …
That’s all

You must anderstand so if i don’t any account and password for trying atersik like beta, that can i do with it?

So i asked simply if somebody can help me.

I am disappointed

i think the idea is that you configure the entire box from the GUI, removing the requirement to have a root-level user. if that’s the theory it’s (imo) flawed, but a practice worth exploring.

doesn’t Ubuntu do something similar ?

Yes, it’s same.

I trying to make a complet installation (Os, Astersik, GUI …etc). and see, and try

else, thak’s for your help.


You set the password for the gui on your first login. specify admin for user and type in whatever password you want to use. Then click the system configuration link (top right) to change the password for the root. Note that the login for the system configuration for Rpath is admin with a password of password (the screen notes this.)

Once you have logged in you can change the password for either admin or root. As you have already specified the password for admin now is the time to specify the password for root. I didn’t try but you might even try password as the password for root before you go to the system configuration.

Hope this helps.


Use Putty to access your server
Login with username: admin and password: (the password you gave during the installation)

Now type the command:

sudo nano /etc/asterisk/manager.conf

find the section [admin] and look for "secret="
The next word is the password for the GUI and should be the same as the password during the installation.
If the password contains any of the characters "!@#$%^&* etc the system won’t let you log in. So change it to something simple like "test"
Press CTRL+X and Y to save the file. Now you can login to the GUI using username: admin and password:test