Passing calls between servers


I am trying to pass calls between two asterisk servers. I have been succesfully using a provider and a single asterisk server for a while… however I member of staff wants to work from home. So I have built a second asterisk server for them on their linux computer.

I have successfully allowed the home server to make outgoing calls through the office server but when the office server tries to pass calls to the home server is fails:

This is how I have set it up:

Office Server Configs

In iax.conf - The office server (with a fixed IP address) allows the home to register,

context=internal ; we are going to route claires phones as internal

Extension Config - when someone dial 151 on Office Server it should pass calls to Home Server, but doesn’t

;claire extension routing
exten => 151,1,Dial(IAX2/claire_usa,20,r)
exten => 151,2,VoiceMail(151@internal)
exten => 151,102,VoiceMail(151@internal) ; this is because busy lines goto n+101[/code]

Home Server Configs

[code]iax.conf. Home server registers with office server

register => claire_usa:password@ipaddress


In Extensions.conf - it sends all calls to office server, everything. Everything in direction works no problem

exten => _.,1,Monitor(wav,${TIMESTAMP}${CALLERIDNUM}-${EXTEN}.wav)
exten => _.,n,Dial(IAX2/Server_A/${EXTEN})
exten => _.,n,Congestion()
exten => _.,n,Busy()[/code]

Am I suppose to register in both direction? I can’t do this as the home server is always changing IP address.

Have I got something wrong with the registering configs? Am I missing some magical setting or password etc?

I am using Asterisk 1.2.x on ubuntu linux on both server,
I would be very gratefull for your comments and help,


Kinda curious why you installed asterisk on the user’s home pc when you could have installed a soft phone. VPN issues?

For some reason the user’s home PC is not registering with the office server as it should.

So you say the home linux box is dynamic?

good questions.

I didn’t want to install a soft phone as the headsets are really poor quality. Also, I want to get the best possible connection between the home and office. I figured that IAX was the best for that. Maybe that isn’t the best way of doing it… but still I nearly have it working :smile:

Anyhow, the home linux box doesn’t have a fixed ipaddess (it changes each time the internet connection is reset - which is once a day). So, I figured that it should just have to register with the office server and collect the calls.

The home server is definitively registering okay with the office server but it can only send calls but not receive them? Any ideas?


Well a decent 40.00 or better USB headset sounds great when used with a IAX softphone a cheapo BT 102 at 65.00 sounds decent 200.00 gets good one

use the IAX trunk method 2 here and use DDNS … c146259294