packet2packet bridging issue with cisco Call Manager

Initiating a call from Cisco call manager to Asterisk version 1.4.17 ( and previous ) causes and issue. During the initial call setup call manager have the strange habit to not specify the CODEC it will be using it only specifies in the the Acknowledge message.

For example , if i make a call from CCM to asterisk and the call is a G.729 codec. The Codec is not specified in the notify message and Asterisk will forward a notify message to my phone specifying a default codec that is rtpmap: 0 (PCMU/8000) ( mean G711 ulaw ). Then when i answer my phone ( polycom ip soundpoint 301 ) the asterisk server start a new feature call packet2packet bridging. I guess you all saw me coming, the incoming stream from the call manager is g729 and the outgoing stream is g711 therefore we don’t hear anything on both ends.

I need a way to disable Packet2packet bridging ?
Where should i post a request for this feature if it is not here ?